Telerik require .net framework 4.5 with ie11?

2 posts, 0 answers
  1. Bryian
    Bryian avatar
    4 posts
    Member since:
    May 2013

    Posted 28 Feb 2014 Link to this post

    When using the latest DLL, I see some strange error on ie 11. The error will go away if I switch to ie 11 compatibility mode. But the it start to work fine after I installed the .net framework 4.5 on the server. My question is, if anyone know the UI for ASP.NET AJAX required .NET Framework 4.5 to be installed on the server in order for the application to work correctly with ie11?

    Unable to get property ‘PageRequestManager’ of undefined or null reference
    webform_doPostBack is undefined JavaScript error 

  2. Slav
    Admin
    Slav avatar
    1355 posts

    Posted 05 Mar 2014 Link to this post

    Hello Bryian,

    Versions 3.5 and 4.0 of .NET Framework are supported by UI for ASP.NET AJAX as well. Most probably you have encountered the ASP.NET browser detection issue that is described in the following sticky forum thread: http://www.telerik.com/forums/incorrectly-rendered-webpage-when-using-internet-explorer-11. The thread contains several approaches to resolve this issue, one of which is upgrading to .NET 4.5.

    Regards,
    Slav
    Telerik

    DevCraft Q1'14 is here! Join the free online conference to see how this release solves your top-5 .NET challenges. Reserve your seat now!

  3. UI for ASP.NET Ajax is Ready for VS 2017
Back to Top