Telerik Control Panel settings crash

7 posts, 0 answers
  1. Cezary
    Cezary avatar
    13 posts
    Member since:
    Jan 2011

    Posted 25 Oct 2013 Link to this post

    Hello,
    I have a problem with control panel. When I'm trying to get into settings panel (to set up "Keep older versions") the app is getting error "System.InvalidOperationException: Password decryption failed." (more in the attached screenshot). I tried to reinstall that, with no result. It's showing every time im clicking on settings icon.

  2. Dyanko
    Admin
    Dyanko avatar
    122 posts

    Posted 25 Oct 2013 Link to this post

    Hi Cezary,

    Thank you for contacting us.

    This error might occur if the User data files which are used by the Telerik Control Panel are somehow corrupted. In order to make sure that the User data files are not corrupted and causing the issue I would suggest performing the following steps:
    1. Open a Windows Explorer window and navigate to %appdata%\Telerik\Installer\UserSettings
    2. Delete the content of the folder (LoginData, NotificationAuthenticationData and User.data files)

    After these steps, please try to run the Telerik Control Panel again and try to apply your settings.

    Please let me know if the issue still occurs.

    Regards,
    Dyanko
    Telerik

    Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Cezary
    Cezary avatar
    13 posts
    Member since:
    Jan 2011

    Posted 28 Oct 2013 Link to this post

    Hi,
    unfortunately it has not help. Same problem still.
  5. Dyanko
    Admin
    Dyanko avatar
    122 posts

    Posted 31 Oct 2013 Link to this post

    Hello Cezary,

    I am sorry that did not help.

    We investigated the problem and would suggest to delete the following system file:
    C:\Users\[UserName]\AppData\Roaming\Microsoft\Crypto\DSS\S-1-5-21-2202275740-2602787589-1272277452-1001\d47939946c8d19c7b892d4db2c1ba6c5_e970eb7d-53a8-463c-a205-859c6533bd9f

    Then after a restart the system regenerates the same file automatically. I would suggest performing that step and give it another try.

    Please let me know if the issue still occurs.

    Regards,
    Dyanko
    Telerik

    Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

  6. Cezary
    Cezary avatar
    13 posts
    Member since:
    Jan 2011

    Posted 05 Nov 2013 Link to this post

    Unfortunately I don't even have the DSS directory in Crypto path. Just RSS. I deleted that, restart Windows, but same result still.
  7. Dyanko
    Admin
    Dyanko avatar
    122 posts

    Posted 05 Nov 2013 Link to this post

    Hello Cezary,

    I am sorry to hear the issue still occurs.

    I would suggest to navigate to the following path and delete the user.config file and then check if the problem rises again:
    %localappdata%\Telerik_AD\TelerikControlPanel.exe_StrongName_[RandomGeneratedName]\[ControlPanelVersion]\

    Note that Telerik Control Panel should be not running when deleting the user.config file.


    Please let me know if the problem still exists.

    Regards,
    Dyanko
    Telerik

    Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

  8. Cezary
    Cezary avatar
    13 posts
    Member since:
    Jan 2011

    Posted 06 Nov 2013 Link to this post

    Hello,
    now the issue just disappears, thank you very much for help.
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017