Telerik.AsyncUpload.TemporaryFolder does not work from machine.config?

3 posts, 0 answers
  1. Margo Noreen
    Margo Noreen avatar
    25 posts
    Member since:
    Mar 2010

    Posted 11 Nov 2013 Link to this post

    I set the appsetting for the temp folder of the AsynchUpload control in my machine.config file.  It does not seem to work there.  By cutting/pasting into my web.config, the setting seems to be picked up.  So, I know the setting is valid.   It looks like the snippet below.

     <add key="Telerik.AsyncUpload.TemporaryFolder" value="\\SomeDevServer\e$\SomeFolder\temp\" />

    While I can leave it in web.config, we find that "unfortunate."  All our file system settings are set in machine.config!  That way we can copy our website files across dev/test/production servers, including web.config without modification.  Now we will have to make custom edits as deploy to different servers.

    Any reason why the appsetting can't be inherited from the machine.config value?
  2. Shinu
    Shinu avatar
    17764 posts
    Member since:
    Mar 2007

    Posted 12 Nov 2013 Link to this post

    Hi Margo,

    It is possible to set the RadAsyncUpload TemporaryFolder from machine.config. Please check the sample settings I tried which works perfectly at my end.

    XML : machine.config
    <configuration>
    ...
    </configSections>
    <appSettings>
        <add key="Telerik.AsyncUpload.TemporaryFolder" value="E:\TempUpload\"/>
    </appSettings>

    Please note that you add these settings after closing the <configSections> in the machine.config. Also check whether these settings are not being overridden from your application.

    Thanks,
    Shinu.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Margo Noreen
    Margo Noreen avatar
    25 posts
    Member since:
    Mar 2010

    Posted 12 Nov 2013 Link to this post

    Shinu --

    Thanks for the reply.  This is my mistake (but something you can add to your arsenal in case others trip over it!)... I have a 64 bit development machine; yet when running on localhost, it seems IIS Express is running in 32 bit mode.  So, of course, that changes the location of the machine.config.

    You have to look in

    C:\Windows\Microsoft.NET\Framework\v4.0.30319\Config

    Not

    C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Config

    That's tripped me up in the past, but I just now remembered it.

Back to Top