tab item header foreground

4 posts, 1 answers
  1. igal a
    igal a avatar
    28 posts
    Member since:
    Oct 2009

    Posted 24 Nov 2009 Link to this post

    when i set the tabitem foreground to black and i click on an other tab it's foreground becomes white,

    how can i stop this behavior?
  2. Answer
    Dimitrina
    Admin
    Dimitrina avatar
    442 posts

    Posted 25 Nov 2009 Link to this post

    Hello igal a,

    In order to stop this behavior , you have to edit the style of RadTabItem. In this way you can apply  a custom theme to any of  our controls. For more information you can follow the link below:
    http://www.telerik.com/help/silverlight/radcontrols-for-silverlight-expression-blend-support.html 

    Please find attached an example. If you have any further question please do not hesitate to ask.

    I hope this will help you.

    Sincerely yours,
    Dimitrina
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  3. UI for WPF is Visual Studio 2017 Ready
  4. Shawn
    Shawn avatar
    39 posts
    Member since:
    Jul 2012

    Posted 12 Dec 2009 Link to this post

    Hi Dimitrina,

    The solution you posted works if the your application has a fixed theme/color but if you allow the user to select from the different Telerik theme options available then this doesn't work (or if it does, I am not understanding how to implement it properly). I would like to see an approach that allows the user to specify either a color or default to the same text color when the Background Visibility is set to Hidden or Collapsed. I believe this would fix the problem most users are seeing. Another option would be to set the color to match the selected foreground color but change the opacity of the foreground to 25-50% so that it appears different.

    Thoughts,
    Shawn
  5. Dimitrina
    Admin
    Dimitrina avatar
    442 posts

    Posted 16 Dec 2009 Link to this post

    Hi Shawn,

    In order to remove the "animation" behavior from RadTabItem, you will have to modify the control theme. Unfortunately for now, there is no property available which you could use to prevent the animation.

    You can edit only the default theme in Blend. You can find the xaml code for the other themes in the folder..\Themes\OfficeBlue\Themes\Office\Blue.

    All the best,

    Dimitrina
    the Telerik team

     


    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
Back to Top