Spell Check Handler Server Error

4 posts, 0 answers
  1. Laurie
    Laurie avatar
    141 posts
    Member since:
    Feb 2007

    Posted 09 Oct 2008 Link to this post

    I'm getting the following Spell Check Handler Server Error.  I have followed the instructions to add spellchecking for my radeditor, including making sure the radspell directory and its contents is in the App_Data folder and adding the handler in my web.config.  I added it manually by pasting in <add verb="*" validate="false" path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler, Telerik.Web.UI"/> and I had added it automatically, and note that the handler

    <

     

    add path="Telerik.Web.UI.SpellCheckHandler.axd" verb="*" type="Telerik.Web.UI.SpellCheckHandler, Telerik.Web.UI, Version=2008.1.515.20, Culture=neutral, PublicKeyToken=121fae78165ba3d4"

     

     

     

    validate="false" />

     

    was already in there.  They're both in now and I'm still getting the error.  Any ideas?  The error comes up when I try to click on the spellcheck button.

    One potential issue: I'm trying to run RadEditor and RadEditor for Ajax on the same site for testing purposes.  Would there be conflicts?

    Thanks.

    Laurie

    And here's the error message I'm getting in a pop-up:


    Spell Check Handler Server Error:500
    <html>

        <head>

            <title>Configuration Error</title>

            <style>

             body {font-family:"Verdana";font-weight:normal;font-size: .7em;color:black;}

             p {font-family:"Verdana";font-weight:normal;color:black;margin-top: -5px}

             b {font-family:"Verdana";font-weight:bold;color:black;margin-top: -5px}

             H1 { font-family:"Verdana";font-weight:normal;font-size:18pt;color:red }

             H2 { font-family:"Verdana";font-weight:normal;font-size:14pt;color:maroon }

             pre {font-family:"Lucida Console";font-size: .9em}

             .marker {font-weight: bold; color: black;text-decoration: none;}

             .version {color: gray;}

             .error {margin-bottom: 10px;}

             .expandable { text-decoration:underline; font-weight:bold; color:navy; cursor:hand; }

            </style>

        </head>

     

        <body bgcolor="white">

     

                <span><H1>Server Error in '/AgPlanDev' Application.<hr width=100% size=1 color=silver></H1>

     

                <h2> <i>Configuration Error</i> </h2></span>

     

                <font face="Arial, Helvetica, Geneva, SunSans-Regular, sans-serif ">

     

                <b> Description: </b>An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

                <br><br>

     

                <b> Parser Error Message: </b>Could not load file or assembly 'Telerik.Web.UI, Version=2008.1.515.20, Culture=neutral, PublicKeyToken=121fae78165ba3d4' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)<br><br>

     

                <b>Source Error:</b> <br><br>

     

                <table width=100% bgcolor="#ffffcc">

                   <tr>

                      <td>

                          <code><pre>

     

    Line 57:     validate=&quot;false&quot; /&gt;

    Line 58:    &lt;add verb=&quot;*&quot; validate=&quot;false&quot; path=&quot;Telerik.Web.UI.SpellCheckHandler.axd&quot; type=&quot;Telerik.Web.UI.SpellCheckHandler, Telerik.Web.UI&quot;/&gt;

    <font color=red>Line 59:    &lt;add path=&quot;Telerik.Web.UI.SpellCheckHandler.axd&quot; verb=&quot;*&quot; type=&quot;Telerik.Web.UI.SpellCheckHandler, Telerik.Web.UI, Version=2008.1.515.20, Culture=neutral, PublicKeyToken=121fae78165ba3d4&quot;

    </font>Line 60:     validate=&quot;false&quot; /&gt;

    Line 61:    &lt;add path=&quot;Telerik.Web.UI.DialogHandler.aspx&quot; verb=&quot;*&quot; type=&quot;Telerik.Web.UI.DialogHandler, Telerik.Web.UI, Version=2008.2.1001.20, Culture=neutral, PublicKeyToken=121fae78165ba3d4&quot;</pre></code>

     

                      </td>

                   </tr>

                </table>

     

                <br>

     

                <b> Source File: </b> C:\websites\CFFM\BizPlan\working folder\AgPlanDev\web.config<b> &nbsp;&nbsp; Line: </b> 59

                <br><br>

     

                <b>Assembly Load Trace:</b> The following information can be helpful to determine why the assembly 'Telerik.Web.UI, Version=2008.1.515.20, Culture=neutral, PublicKeyToken=121fae78165ba3d4' could not be loaded.<br><br>

     

                <table width=100% bgcolor="#ffffcc">

                   <tr>

                      <td>

                          <code><pre>

     

    WRN: Assembly binding logging is turned OFF.

    To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.

    Note: There is some performance penalty associated with assembly bind failure logging.

    To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

    </pre></code>

     

                      </td>

                   </tr>

                </table>

     

                <br>

     

                <hr width=100% size=1 color=silver>

     

     

  2. Laurie
    Laurie avatar
    141 posts
    Member since:
    Feb 2007

    Posted 09 Oct 2008 Link to this post

    Never mind.  I deleted the second httphandler line and it works just fine.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Ryan
    Ryan avatar
    4 posts
    Member since:
    Oct 2007

    Posted 06 Nov 2009 Link to this post

    Laurie,

    I'm actually still having this issue. Can you tell me which httphandler line you deleted? I tried deleting the dialog, then spell check httphandler line with no success.

    Thanks!
    Ryan
  5. Laurie
    Laurie avatar
    141 posts
    Member since:
    Feb 2007

    Posted 06 Nov 2009 Link to this post

    I ended up removing the one with the version information in it.  The lines I have under handlers now are

                <add name="Telerik_Web_UI_DialogHandler_aspx" verb="*" preCondition="integratedMode" path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler"/>  
                <add name="Telerik_Web_UI_SpellCheckHandler_axd" verb="*" preCondition="integratedMode" path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler"/>  
     

    It was a year ago so I may be a bit fuzzy, but I did copy the above directly from my web.config and the app is working.  Good luck.
Back to Top