Space key not working while editing RadTreeViewItem

4 posts, 1 answers
  1. Tomáš Čeleda
    Tomáš Čeleda avatar
    15 posts
    Member since:
    Sep 2009

    Posted 07 Apr 2011 Link to this post

    Hello,
    I have encountered a problem while editing item in TreeView. I can't write a space character. Steps to reproduce:

    1) open http://demos.telerik.com/silverlight/#TreeView/NodeEditing
    2) select an item and hit F2
    3) write text with some space char
    Problem: the space key does't work. Probably an event is eaten by some selection handler.

    Btw, I originally wanted to set this issue by support ticket but I haven't found submit button there. I would expect it under the description textbox. Am I blind or the button has somehow disappeared? :)

    Regards,
    Tomas Celeda
  2. Answer
    Snejina
    Admin
    Snejina avatar
    3 posts

    Posted 08 Apr 2011 Link to this post

    Hello Tomáš Čeleda,

    Thank you for contacting us! Please take our apologies for the inconvenience caused!
    We have some temporary issues and now everything should  work fine!

    We are aware of this issue in the RadTreeView. The good news is that it has already been fixed. You can try the latest internal build from your account page at www.telerik.com .The fix will be also included in the Q1 2011 SP1 scheduled for 13 April.

    Greetings,
    Snejina
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. DevCraft banner
  4. Abdulrahman Omran
    Abdulrahman Omran avatar
    15 posts
    Member since:
    Jan 2011

    Posted 17 Apr 2011 Link to this post

    Hi,

    i have the same issue and the latest build on my account's page doesn't seem to have the fix.
    i downloaded the latest hotfix and all it did was disabling the ability to type into a textbox !..


    i hope this issue will be fixed some time soon. I have to do a release sometime soon.


    thank you,

  5. Petar Mladenov
    Admin
    Petar Mladenov avatar
    2891 posts

    Posted 18 Apr 2011 Link to this post

    Hello Abdulrahman Omran,

    The issue in the RadTreeView is fixed and you can inspect it in the internal build 0411. Please let us know if you have tried this internal build and the problem has not gone.
    On the other hand, there is an issue when typing in textbox located in RadTileViewItem. Is your problem related ?  This is also fixed but will be included in the official SP1 scheduled for this week.
    Please accept our apologies for any inconvenience caused.

    Kind regards,
    Petar Mladenov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Back to Top