Slider paging issue

2 posts, 0 answers
  1. Joe
    Joe avatar
    31 posts
    Member since:
    Apr 2012

    Posted 25 Sep 2012 Link to this post

    Hello,

    I am having trouble with the slider when using the timebar control.  It has to do with binding the visible period start. If you use the scroll bar to adjust the timebar it sets the visible period correctly. However if you click in the slider bar to page left or page right the visible period binding is not correct.



    Clicking left does not adjust the visible period the first time, however you can see it change and the current selection moves to the right correctly. After that is seems to adjust the visible period however it is still off by the amount not accounted for in the first click on the paging area of the scroll bar. The same issue occurs but in the other direction if you use the page forward of the scroll bar.



    Attached is a project that demonstrates this issue.



    I have the tab header bound to the visible period start to show the visibleperiodstart as the radtimebar is adjusted.



    Thank you,

    Craig
  2. Tsvetie
    Admin
    Tsvetie avatar
    1517 posts

    Posted 28 Sep 2012 Link to this post

    Hello Craig,

    You can only attach images to forum posts and I suppose that is why the attachment you mentioned is missing. Please open a new support ticket for the same problem and send me the test project in it.

    In the meantime, please make sure that you are using TwoWay binding for the following properties - PeriodStart/PeriodEnd. VisiblePeriodStart/VisiblePeriodEnd, SelectionStart/SelectionEnd. This is required because of the coercing mechanism of RadTimeBar. 

    All the best,
    Tsvetie
    the Telerik team

    Time to cast your vote for Telerik! Tell DevPro Connections and Windows IT Pro why Telerik is your choice. Telerik is nominated in a total of 25 categories.

  3. DevCraft banner
Back to Top