Server error, "Could not load file or assembly 'Telerik.Web.UI' or one of its dependencies"

3 posts, 0 answers
  1. Ali
    Ali avatar
    7 posts
    Member since:
    Sep 2010

    Posted 07 Oct 2010 Link to this post

    Hi

    I have problems using the spell checker in RadEditor in Sharepoint.

    This is what I get when I try to run the spellchecker :
     

    I have versions 2010.2.826.20 and 2010.2.826.35 of Telerik.Web.UI.dll in GAC.

     

    I add the languages and the spell checking dropdown box in the tools.xml file as following:

     

    <tools name="InsertToolbar" enabled="true" >

    <tool name="AjaxSpellCheck"/>

    </tools>

     

    <languages>

        <language code="de-DE" title="Deutsch" />

        <language code="en-US" title="Englisch" />

        <language code="fr-FR" title="France" />

        <language code="sv-SE" title="Svenska" />

    </languages>

     

     

    I have the dictionary files in all of the following folders:

    • \Inetpub\Wwwroot\wss\VirtualDirectories\80\App_Data\RadSpell
    • \Program Files\Common Files\Microsoft Shared\Web Server Extensions\wpresources\RadEditorSharePoint\5.8.0.0__1f131a624888eeed\Resources\App_Data\RadSpell
    • \Program Files\Common Files\Microsoft Shared\Web Server Extensions\wpresources\RadEditorSharePoint\5.8.1.0__1f131a624888eeed\Resources\App_Data\RadSpell

     

    This is how my web.config httpHandlers section looks like:

     

        <httpHandlers>

          <remove verb="GET,HEAD,POST" path="*" />

          <add verb="GET,HEAD,POST" path="*" type="Microsoft.SharePoint.ApplicationRuntime.SPHttpHandler, Microsoft.SharePoint, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" />

          <add verb="OPTIONS,PROPFIND,PUT,LOCK,UNLOCK,MOVE,COPY,GETLIB,PROPPATCH,MKCOL,DELETE,(GETSOURCE),(HEADSOURCE),(POSTSOURCE)" path="*" type="Microsoft.SharePoint.ApplicationRuntime.SPHttpHandler, Microsoft.SharePoint, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" />

          <add verb="*" path="Reserved.ReportViewerWebControl.axd" type="Microsoft.Reporting.WebForms.HttpHandler, Microsoft.ReportViewer.WebForms, Version=8.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />

          <add verb="*" path="*.asmx" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />

          <add verb="*" path="*_AppService.axd" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />

          <add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" validate="false" />

          <add path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler" verb="*" validate="false" />

          <add path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler, Telerik.Web.UI" verb="*" validate="false" />

        </httpHandlers>

     

    And finally, in the onload method of the user control I tried any combination of the following lines of code, as well as any possible option for the SpellCheckProvider enumeration.

                editor.SpellCheckSettings.AllowAddCustom = true;

                editor.SpellCheckSettings.SpellCheckProvider = SpellCheckProvider.MicrosoftWordProvider;

                editor.SpellCheckSettings.EditDistance = 2;

                editor.SpellCheckSettings.AjaxUrl = "Telerik.Web.UI.SpellCheckHandler.axd";

     

    FYI I am using the rad editor inside a roddock which is in a web user control. The web user control in turn is loaded into a sharepoint webpart.
    I appreciate your help.
    Ali

  2. Stanimir
    Admin
    Stanimir avatar
    1653 posts

    Posted 12 Oct 2010 Link to this post

    Hi Ali,

    I can see that you are using RadEditor for MOSS. So when it comes to MOSS we recommend using MOSSRadEditor, which is defined in the Telerik.SharePoint namespace of the RadEditorSharePoint assembly. Once you use this control you do not need the following entries in the web.config:
    <add path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler" verb="*" validate="false" />
     
          <add path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler, Telerik.Web.UI" verb="*" validate="false" />

    If you still decide to use RadEditor instead MOSSRadEditor make sure that you always use fully qualified names when you register the handlers. Also review the following online KB article: http://www.telerik.com/support/kb/aspnet-ajax/editor/error-web-config-registration-missing-the-telerik-dialogs-require-a-httphandler-registration-in-the-web-config-file.aspx

    Best wishes,
    Stanimir
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Ali
    Ali avatar
    7 posts
    Member since:
    Sep 2010

    Posted 08 Nov 2010 Link to this post

    Thanks. I replaced RadEditor with MOSS RadEditor and the problem is now solved.
    Ali
Back to Top