Scroll Bars in Page View

2 posts, 0 answers
  1. Don
    Don avatar
    40 posts
    Member since:
    Apr 2009

    Posted 07 May 2014 Link to this post

    So I think what I have is pretty straight forward. I have a tab strip with page views associated with each one. I have the scroll bars set to auto. They do not show up if the content stretches beyond the page. If I set the scroll bars to vertical they show but there is no way to scroll since the handle stretches the entire length of the bar. What do I have to do to make the scroll bars actually work?

    <telerik:RadTabStrip SelectedIndex="0" ID="RadTabStrip1" runat="server" MultiPageID="RadMultiPage1">
       <Tabs>
          <telerik:RadTab Text="Today" PageViewID="RadPageView1" runat="server" />
          <telerik:RadTab Text="Personnel" PageViewID="RadPageView2" runat="server" />
          <telerik:RadTab Text="Availability" PageViewID="RadPageView3" runat="server" />
          <telerik:RadTab Text="Schedule" PageViewID="RadPageView4" runat="server" />
       </Tabs>
    </telerik:RadTabStrip>
     
    <telerik:RadMultiPage ID="RadMultiPage1" runat="server" SelectedIndex="0" ScrollBars="Auto">
       <telerik:RadPageView ID="RadPageView1" runat="server">
          <uc1:TSTodayAlertControl ID="TSTodayAlert" runat="server" />
       </telerik:RadPageView>
       <telerik:RadPageView ID="RadPageView2" runat="server">
          <uc2:TSUserInfoControl ID="TSUserInfo" runat="server" />
       </telerik:RadPageView>
       <telerik:RadPageView ID="RadPageView3" runat="server">
          <uc3:TSAvailabilityControl ID="Availability" runat="server" />
       </telerik:RadPageView>
       <telerik:RadPageView ID="RadPageView4" runat="server">
          <uc4:TSScheduleControl ID="Scheduling" runat="server" />
       </telerik:RadPageView>
    </telerik:RadMultiPage>
  2. Shinu
    Shinu avatar
    17764 posts
    Member since:
    Mar 2007

    Posted 08 May 2014 in reply to Don Link to this post

    Hi,

    Please have a look into the sample code snippet which works fine at my end also take a look into this help documentation.

    ASPX:
    <telerik:RadTabStrip ID="RadTabStrip1" runat="server" MultiPageID="RadMultiPage1">
        <Tabs>
            <telerik:RadTab Text="Tab1" runat="server" PageViewID="RadPageView1">
            </telerik:RadTab>
            <telerik:RadTab Text="Tab2" runat="server" PageViewID="RadPageView2">
            </telerik:RadTab>
        </Tabs>
    </telerik:RadTabStrip>
    <telerik:RadMultiPage ID="RadMultiPage1" runat="server" ScrollBars="Auto">
        <telerik:RadPageView ID="RadPageView1" runat="server" Height="150px">
            <iframe id="IFrame1" runat="server" frameborder="1" src="Clientheight.aspx" height="55px">
            </iframe>
        </telerik:RadPageView>
        <telerik:RadPageView ID="RadPageView2" ContentUrl="../Images/images.jpg" runat="server">
        </telerik:RadPageView>
    </telerik:RadMultiPage>

    Thanks,
    Shinu.
     
  3. UI for ASP.NET Ajax is Ready for VS 2017
Back to Top