Scheduler - Maximum request length exceeded.

5 posts, 1 answers
  1. Jagat
    Jagat avatar
    135 posts
    Member since:
    Jan 2011

    Posted 03 Mar Link to this post

    Hi,

    We use a scheduler in our site which by default loads all the appointments for everyone on that given day.

    We have a separate drop down which has user names. When a username is selected from the list, schedule for that user is loaded in the scheduler.

    When the scheduler is empty , it loads well.

    In some cases where the calendar is full with appointments, when i select a user from the drop down, I get the error given below. I get this error before it goes to  dropdown_selectedindexchange event.  Does this have anything to do with the view state? What fix is needed to get it working ?

     

    'System.Web.HttpUnhandledException' was thrown. ---> System.Web.HttpException: Maximum request length exceeded.
       at System.Web.HttpRequest.GetEntireRawContent()
       at System.Web.HttpRequest.FillInFormCollection()
       at System.Web.HttpRequest.get_Form()
       at System.Web.HttpRequest.get_HasForm()
       at System.Web.UI.Page.GetCollectionBasedOnMethod(Boolean dontReturnNull)
       at System.Web.UI.Page.DeterminePostBackMode()
       at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

     

     

    Thanks,

    Ravi

  2. Jagat
    Jagat avatar
    135 posts
    Member since:
    Jan 2011

    Posted 04 Mar in reply to Jagat Link to this post

    I disabled view state on the control to see if it helps. 

    It helped me to see the appointments for the day but now, i cannot see the week view or month view.

     

    Any help on this issue is appreciated.

    Thanks in Advance

  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Answer
    Ivan Danchev
    Admin
    Ivan Danchev avatar
    829 posts

    Posted 08 Mar Link to this post

    Hello Jagat,

    Have you set a value to the maxRequestLength property in the web.config? If you haven't its default value (4096 KB) will be used. If you are operating with large amount of data it might be exceeding this threshold, so you could try increasing it to 32 MB for instance. This can be done by adding the following to the system.web section in your web.config file:
    <httpRuntime maxRequestLength="32768" />

    For IIS the property that has to be set is maxAllowedContentLength and its value is in bytes. The following has to be added to the system.webServer section:
    <security>
        <requestFiltering>
            <requestLimits maxAllowedContentLength="33554432" />
        </requestFiltering>
    </security>

    Let us know whether this resolves the issue or the exception is still present.

    Regards,
    Ivan Danchev
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  5. Jagat
    Jagat avatar
    135 posts
    Member since:
    Jan 2011

    Posted 18 Mar in reply to Ivan Danchev Link to this post

    This worked. 

     

    Thanks,

  6. Ivan Danchev
    Admin
    Ivan Danchev avatar
    829 posts

    Posted 21 Mar Link to this post

    Hello Jagat,

    Thank you for getting back to us. I am glad we were able to help and the issue is resolved.

    Regards,
    Ivan Danchev
    Telerik
    Do you need help with upgrading your ASP.NET AJAX, WPF or WinForms projects? Check the Telerik API Analyzer and share your thoughts.
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017