Reusable content is inserted in the wrong location (IE8)

7 posts, 1 answers
  1. eef
    eef avatar
    2 posts
    Member since:
    Jul 2007

    Posted 15 May 2009 Link to this post

    Reusable content is inserted in the wrong location IE8

    When I use the template picker to insert some reusable html content  in the Rad editor the HTML snippet is inserted not in the text editor, but shows up in the page.

    Details:

     

    • IE8 (IE7 and IE6 work as expected)
    • MOSS SP1 and MOSS SP2
    • RadEditorMOSS_4_5_0 and RadEditorMOSS_4_5_6

    The snippet is inserted in the page just below:

    <form name="aspnetForm" id="aspnetForm" action="Homepage.aspx" method="post" submit="function(){try{RadEditorNamespace.SaveAllEditors();var _a0=this.submit;this.submit=_9f;var _a1=this.submit();this.submit=_a0;}catch(exc){}}">  
    <snippet is inserted here><rest of page... 

    The snippet does not showup in the editor iframe and is not saved with the edited content.

    Please help,

    Regards, Evert

  2. Answer
    Stanimir
    Admin
    Stanimir avatar
    1653 posts

    Posted 18 May 2009 Link to this post

    Hello Evert,

    Thank you for the provided information. I was able to reproduce your problem. What you need to do is  replace the MOSSEditorTools.js file, which is located in the Program Files\Common Files\Microsoft Shared\web server extensions\wpresources\RadEditorSharePoint\4.5.6.0__1f131a624888eeed\RadControls\Editor\Scripts\7_3_6 folder, with the one that I attached to this thread.



    Sincerely yours,
    Stanimir
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.

  3. eef
    eef avatar
    2 posts
    Member since:
    Jul 2007

    Posted 18 May 2009 Link to this post

    Thanks a lot! The issue is fixed.
  4. Brian
    Brian avatar
    1 posts
    Member since:
    May 2009

    Posted 02 Jun 2009 Link to this post

    Will this be fixed in a hotfix / release?

    I would prefer not to have to copy the file in manually on a production setup.
  5. Stanimir
    Admin
    Stanimir avatar
    1653 posts

    Posted 02 Jun 2009 Link to this post

    Hi Brian,

    Unfortunately we do not release newer versions of RadEditor for MOSS 4.x very often (the Lite version of RadEditor for MOSS is based on it). What I suggest you is to get the full version of RadEditor for MOSS 5.4.1, which is based on the latest RadEditor for ASP.NET AJAX 2009.1.530.20.


    Greetings,
    Stanimir
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  6. Christy
    Christy  avatar
    4 posts
    Member since:
    Feb 2008

    Posted 17 Jul 2009 Link to this post

    Hello,
    I have the same problem and I am using the rad editor lite 4.4.0 is what I believe our version is.  Would the MOSSEditorTools.js file that was attached to this post work on that version also to fix the IE8 and reusuable content issue?  Please let me know.  Thank you.  Christy
  7. Stanimir
    Admin
    Stanimir avatar
    1653 posts

    Posted 20 Jul 2009 Link to this post

    Hello Christy ,

    I attached MOSSEditorTools.js file, which is for rad editor lite 4.4.0.

    I hope this helps.

    Kind regards,
    Stanimir
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
Back to Top