RadWindow disastrous: whatever RadWindow, Popup, Alert and so on: ArgumentException

5 posts, 0 answers
  1. Gregor Daskaloff
    Gregor Daskaloff avatar
    6 posts
    Member since:
    Sep 2012

    Posted 08 Dec 2009 Link to this post

    Hi,
    I have typed the following text in Google-translator, so it goes faster, so please excuse any errors.
    I have the following problem with the WPF RadWindows:
    Whenever it opens, is thrown a System.ArgumentException. Whether it's own window, or create the controls of their choice.
    The windows are always at the upper corner of the screen. If I want to move the window, thrown the exception.
    Here is a screenshot of a window of RadShedule: http://img1.bildupload.com/4ed9dbb35ad45e65eb4bc6814fa455cf.jpg and as attachment.

    I searched for this error (google and Telerik) and have found several entries. Unfortunately, none has been solved so far.
    I've tried the following workarounds:
    1. Catch the ecxeption in app_DispatcherUnhandledException does work, but the application also crashes after short time (when moving), so no solution
    2. refer to this thread: http://www.telerik.com/community/forums/silverlight/gridview/radgridview-exception-onclose-of-radwindow.aspx: still no solution
    3. i found this: http://www.telerik.com/community/forums/silverlight/window/exception-value-does-not-fall-within-the-expected-range-when-displaying-nested-rad-windows.aspx, but there is also no solution, only a reference at the HACKS class (but this is still private, perhaps in the internal user) you.

    I'm desperate, I can indeed use for my own window, the standard Window class, but all of the windows, for example RadShedule are RadWindows.
    The error also appears in your wpf example application. (detailed see screenshots):

    http://img1.bildupload.com/1c6f66118fa997a217583dbfeb422b91.jpg
    http://img1.bildupload.com/b5d4ab2f5cdc6b38f735a9cc0f21c441.jpg

    But...,
    in Silverlight the moving, resizing and closing and reopening of the window works with no problems: http://img1.bildupload.com/60332521dc5deec8783c99ae08dc5f84.jpg


    I would like to thank you very much if you could deal with the problem, since all other contributions were offered no further assistance or solutions. I can send you all important project data, unless you can reproduce the problem.
    Can it possibly be constellation problem with my system. If you suspect this, I send you also necessary system parameters (os: Vista Ultimate 64-bit video card: NVIDIA 9800 SLI (2 units) and so on)

    Many many thanks in advance.
    Gregor Daskaloff

  2. Gregor Daskaloff
    Gregor Daskaloff avatar
    6 posts
    Member since:
    Sep 2012

    Posted 08 Dec 2009 Link to this post

    On my notebook (Vista Home Premium 32-Bit) the Telerik RadWindow examples in the example application for wpf works fine, there are no errors.
    that means on my main development machine must be a system misconfiguration or something else.
    But what could cause the "ArgumentException" in UIAutomationProvider?
    (Framework version and application versions (vs and blend) are the same)

    Thanks in advance.

  3. UI for WPF is Visual Studio 2017 Ready
  4. Miroslav Nedyalkov
    Admin
    Miroslav Nedyalkov avatar
    1718 posts

    Posted 11 Dec 2009 Link to this post

    Hello Gregor,

     It is not common to suggest doing a remote session, but as the problem looks very odd, would like to schedule a GoToMeeting session and try to figure out what the problem is?


    Regards,
    Miroslav Nedyalkov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  5. Graham
    Graham avatar
    5 posts
    Member since:
    Sep 2009

    Posted 11 May 2010 Link to this post

    Hi Guys,
    I am facing the same problem - did find a solution?
    //Graham.
  6. Miroslav Nedyalkov
    Admin
    Miroslav Nedyalkov avatar
    1718 posts

    Posted 11 May 2010 Link to this post

    Hi Graham,

     What version of the RadControls for WPF do you use? This problem shouldn't appear in the latest version any more.

    Sincerely yours,
    Miroslav Nedyalkov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
Back to Top
UI for WPF is Visual Studio 2017 Ready