RadSpell Web.config 404 error

13 posts, 1 answers
  1. Stephen
    Stephen avatar
    2 posts
    Member since:
    Jan 2012

    Posted 18 Jan 2012 Link to this post

    I looked through the forums but I was unable to find a solution to my issue with RadSpell. We are currently running IIS 6 and I think this issue appeared after moving to .NET 4.0 and enabling MVC. The version of Telerik is 2010.1.519.35.

    When I click on the spell check button, the following dialog popup appears:

    Web.config registration missing!
    The spellchecking functionality requires a HttpHandler registration in web.config. Please, use the control Smart Tag to add the handler automatically, or see the help for more information.

    Telerik.Web.UI.SpellCheckHandler.axd


    The Chrome debug shows an HTTP 404 error for:

    Requested URL: /Web/Telerik.Web.UI.SpellCheckHandler.axd


    The Web.config file shows:

            <httpHandlers>
                <remove verb="*" path="*.asmx"/>
                <add verb="*" path="*.asmx" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
                <add verb="*" path="*_AppService.axd" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
                <add verb="GET,HEAD" path="ScriptResource.axd" validate="false" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
                <add verb="*" validate="false" path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler, Telerik.Web.UI"/>
                <add verb="*" validate="false" path="Telerik.Web.UI.DialogHandler.axd" type="Telerik.Web.UI.DialogHandler, Telerik.Web.UI"/>
                <add verb="*" validate="false" path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource, Telerik.Web.UI"/>
            </httpHandlers>
            <handlers/>


    Does anyone know how to fix this config issue?

    Thanks!
  2. Answer
    Rumen
    Admin
    Rumen avatar
    12849 posts

    Posted 20 Jan 2012 Link to this post

    Hi,

    Can you please set the

    AjaxUrl="/Telerik.Web.UI.SpellCheckHandler.axd"

    property to the RadSpell declaration and test again.

    If you use RadSpell in RadEditor set SpellCheckSettings-AjaxUrl="/Telerik.Web.UI.SpellCheckHandler.axd", e.g.

    <telerik:RadEditor ID="RadEditor1" SpellCheckSettings-AjaxUrl="/Telerik.Web.UI.SpellCheckHandler.axd" DialogHandlerUrl="~/Telerik.Web.UI.DialogHandler.axd" runat="server">
    </telerik:RadEditor>


    All the best,
    Rumen
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Stephen
    Stephen avatar
    2 posts
    Member since:
    Jan 2012

    Posted 20 Jan 2012 Link to this post

    It works great - thanks!
  5. Rayne
    Rayne avatar
    241 posts
    Member since:
    Sep 2010

    Posted 30 Jan 2012 Link to this post

    I'm having the same problem with the spell checker. I get the error message about "Web.config registration missing! "

    I deleted the entry in my web.config that has the handler and the smart tag option reappeared. Clicked it to add http handlers. Then added the suggested AjaxURL but I'm still getting that error.

    I've update my project to the latest version today (before attempting to use the spell check in my project), so I should have the most recent version.

    What else could be causing this message to show up?
  6. Rumen
    Admin
    Rumen avatar
    12849 posts

    Posted 31 Jan 2012 Link to this post

    Hello,

    Open the web.config file and check whether you have runtimeVersionv2.0 in the handler:

    <add name="Telerik_Web_UI_SpellCheckHandler_axd" path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler" verb="*" preCondition="integratedMode,runtimeVersionv2.0"/>

    It should be changed to:

    <add name="Telerik_Web_UI_SpellCheckHandler_axd" path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler" verb="*" preCondition="integratedMode"/>


    Greetings,
    Rumen
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now
  7. Rayne
    Rayne avatar
    241 posts
    Member since:
    Sep 2010

    Posted 31 Jan 2012 Link to this post

    Nope. My config looks like the second one without the runtimeVersion
  8. Rumen
    Admin
    Rumen avatar
    12849 posts

    Posted 31 Jan 2012 Link to this post

    Hello,

    Try the following:

    in the RadSpell declaration:
    <telerik:RadSpell ID="RadSpell1" runat="server" AjaxUrl="~/Telerik.Web.UI.SpellCheckHandler.ashx" HandlerUrl="~/Telerik.Web.UI.DialogHandler.axd" ControlsToCheck="TextBox1" />

    and in the web.config file register the handlers as follows:

    <httpHandlers>
    <add path="Telerik.Web.UI.DialogHandler.axd" type="Telerik.Web.UI.DialogHandler" verb="*" validate="false"/>
    <add path="Telerik.Web.UI.SpellCheckHandler.ashx" type="Telerik.Web.UI.SpellCheckHandler" verb="*" validate="false"/>

    </httpHandlers>

    ...

    <system.webServer>
    <modules runAllManagedModulesForAllRequests="true"/>
    <validation validateIntegratedModeConfiguration="false"/>
    <handlers>
    <add name="Telerik_Web_UI_DialogHandler_axd" verb="*" preCondition="integratedMode" path="Telerik.Web.UI.DialogHandler.axd" type="Telerik.Web.UI.DialogHandler"/>
    <add name="Telerik_Web_UI_SpellCheckHandler_ashx" verb="*" preCondition="integratedMode" path="Telerik.Web.UI.SpellCheckHandler.ashx" type="Telerik.Web.UI.SpellCheckHandler"/>
    </handlers>
    </system.webServer>


    All the best,
    Rumen
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now
  9. Rayne
    Rayne avatar
    241 posts
    Member since:
    Sep 2010

    Posted 31 Jan 2012 Link to this post

    Thank you. That seemed to fix the problem. 
  10. BiBongNet
    BiBongNet avatar
    27 posts
    Member since:
    May 2010

    Posted 16 Oct 2012 Link to this post

    Thank you, Rumen.

    Your suggestion DOES work for me. You save me, and "~" kills me! :D
    I set SpellCheckSettings-AjaxUrl="/Telerik.Web.UI.SpellCheckHandler.axd" and It is OK. But SpellCheckSettings-AjaxUrl="~/Telerik.Web.UI.SpellCheckHandler.axd" (with "~") never works. Never think of this.

    Thank you.
  11. Simbu
    Simbu avatar
    2 posts
    Member since:
    Jan 2013

    Posted 09 Apr 2013 Link to this post

    Hi Rumen,

     I am also facing the above issue in the sharepoint server 2010 environment. Following are my code: Please have look on this and try give me the solution AEAP.

    Following code in the ASPX Page

     <telerik:RadEditor AjaxUrl="/Telerik.Web.UI.SpellCheckHandler.ashx" DialogHandlerUrl="~/Telerik.Web.UI.DialogHandler.axd"
                                                    runat="server" ID="rdEditor">
                                                    <%-- <Languages>
                                                        <telerik:SpellCheckerLanguage Code="en-US" Title="English" />
                                                    </Languages>--%>
                                                </telerik:RadEditor>


    Following code in the Web.Config File
     <system.web>
     <httpHandlers>
          <add path="Telerik.Web.UI.DialogHandler.axd" type="Telerik.Web.UI.DialogHandler" verb="*" validate="false" />
          <add path="Telerik.Web.UI.SpellCheckHandler.ashx" type="Telerik.Web.UI.SpellCheckHandler" verb="*" validate="false" />
        </httpHandlers>
     </system.web>

      <system.webServer>
     <handlers>

     <validation validateIntegratedModeConfiguration="false" />
     <modules runAllManagedModulesForAllRequests="true">
     <add name="Telerik_Web_UI_DialogHandler_axd" verb="*" preCondition="integratedMode" path="Telerik.Web.UI.DialogHandler.axd" type="Telerik.Web.UI.DialogHandler" />
          <add name="Telerik_Web_UI_SpellCheckHandler_ashx" verb="*" preCondition="integratedMode" path="Telerik.Web.UI.SpellCheckHandler.ashx" type="Telerik.Web.UI.SpellCheckHandler" />

     </handlers>
      </system.webServer>

    Thanks,
    Simbu
  12. Dobromir
    Admin
    Dobromir avatar
    1633 posts

    Posted 11 Apr 2013 Link to this post

    Hello,

    When it comes to SharePoint 2010 we always recommend using the specially designed RadEditor for SharePoint 2010.  On of the reasons for this is exactly the control's dialogs. Also there is implemented a content provider, which work with SharePoint's libraries. In order to use it, install the RadEditor for SharePoint 2010: http://www.telerik.com/help/aspnet-ajax/moss-installing_radeditor__radgrid_web_parts_on_sharepoint_2010.html. Then in you custom web solution you can use the SPRadEditor class, which is defined in the Telerik.SharePoint namespace of the RadEditorSharePoint assembly.

    Regards,
    Dobromir
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  13. Sathish
    Sathish avatar
    25 posts
    Member since:
    Dec 2008

    Posted 27 Nov 2013 Link to this post

    i am working on a project that involves radeditor, not the sharepoint one and it has already been used and everything except the spell check. i get the following error:

    Sys.ArgumentException: Sys.ArgumentException: Cannot deserialize. The data does not correspond to valid JSON. Parameter name: data
    Is there anyway I can fix this without sharepoint editor? i dont want to replace the controls and rework everything.

    the handlers are registered correctly in the web config.

    i DONT have the setting below though, but looks like having this did not solve the problem for Simbu.
    <telerik:RadEditor AjaxUrl="/Telerik.Web.UI.SpellCheckHandler.ashx"

    We are using the telerik 2013.2.611.35 dlls..

    changing to MOSS editor means a lot of rework. hopefully there is a solution without it. please help.
  14. Marin Bratanov
    Admin
    Marin Bratanov avatar
    3598 posts

    Posted 29 Nov 2013 Link to this post

    Hi Sathish,

    If you are working under a SharePoint environment, it is recommended that you use the SharePoint RadEditor.
    Otherwise, you simply need to add the spellcheck and dialog handlers in the web.config:
    for IIS6:
    <httpHandlers>
      <add path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler" verb="*" validate="false" />
      <add path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler" verb="*" validate="false" />
      <add path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" verb="*" validate="false" />
    </httpHandlers>
    and for IIS7+ :
    <handlers>
      <remove name="Telerik_Web_UI_SpellCheckHandler_axd" />
      <add name="Telerik_Web_UI_SpellCheckHandler_axd" path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler" verb="*" preCondition="integratedMode" />
      <remove name="Telerik_Web_UI_DialogHandler_aspx" />
      <add name="Telerik_Web_UI_DialogHandler_aspx" path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler" verb="*" preCondition="integratedMode" />
      <remove name="Telerik_Web_UI_WebResource_axd" />
      <add name="Telerik_Web_UI_WebResource_axd" path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" verb="*" preCondition="integratedMode" />
    </handlers>

    and, of course, add the ditionaries to the App_Data folder.

    Nevertheless, on problems with deserialization you can also take a look at the following articles to see if the information there helps:
    http://www.telerik.com/help/aspnet-ajax/editorcannotdeserializedialogparameters.html
    http://www.telerik.com/help/aspnet-ajax/editor-blankdialogsproblem.html
    http://www.telerik.com/help/aspnet-ajax/editor-httphandlers-and-authentication.html


    If neither helps, please explain the scenario you have, what you have attempted so far, and what the exact problem is, because at this point I am left guessing.

    Regards,
    Marin Bratanov
    Telerik
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to the blog feed now.
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017