RadMenu skins not showing

7 posts, 0 answers
  1. Daniel
    Daniel avatar
    8 posts
    Member since:
    Oct 2008

    Posted 08 Oct 2008 Link to this post

    I'm following the examples in the Telerik Trainer for the RadMenuOverview.tts and I can't see the "Skin" in the drowdown of the controls design view. 

    I don't have the 'ASP.NET AJAX-Enabled Web Site' template so I used the 'ASP.NET Web Application' template in Visual Studio Team System 2008. The only thing difference is supposed to be the 'asp:ScriptManager' is added to the Default.aspx. At least that is all that was mentioned in the two training vids I have seen. So I added it.

    I noticed the path in the properties of the RadMenu1 of 'SkinsPath' and that was a default setting of '~/RadControls/Menu/Skins'. So I made that path in my project and placed the 'Skins' in there that came with the Telerik install '..\Telerik\RadControls for ASPNET AJAX Q2 2008\Skins'. Still I don't see the skins.

    Please post any thoughts that you think might help me see the skins in the design view of the RadMenu.

    Thank  you
  2. Serrin
    Serrin avatar
    286 posts
    Member since:
    Sep 2008

    Posted 08 Oct 2008 Link to this post

    Hey Daniel,

    Did you do the manual installation or the self-install?  Trying to figure out what may go wrong to get that normal functionality to not be present...
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Daniel
    Daniel avatar
    8 posts
    Member since:
    Oct 2008

    Posted 08 Oct 2008 Link to this post

    Hi Mark - I did a default complete install using the 'RadControls_for_ASP.NET_AJAX_2008_2_723_dev.exe'. After seeing your post I uninstalled Telerik, rebooted, installed again, rebooted, and tried the control again to see that I don't have any skins.

    Do you know what I should check? Thanks
  5. Alex Gyoshev
    Admin
    Alex Gyoshev avatar
    2500 posts

    Posted 09 Oct 2008 Link to this post

    Hello Daniel,

    The video targets the RadMenu for ASP.NET AJAX. Since it doesn't have a SkinsPath, I assume that you are using a RadMenu Classic instead. If that is not the case, could you send some source code so that we investigate the issue?

    Best wishes,
    Alex
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  6. Daniel
    Daniel avatar
    8 posts
    Member since:
    Oct 2008

    Posted 09 Oct 2008 Link to this post

    Hi Alex,

    I have zipped up the test project and replied to the thread e-mail with address of 'support@telerik.com'. It says not to reply to the e-mail but I don't know where else to send it. If this is not the address you would like me to send the project to please let me know where you would like me to send the test project.

    Thank you,

    Daniel 
  7. Alex Gyoshev
    Admin
    Alex Gyoshev avatar
    2500 posts

    Posted 10 Oct 2008 Link to this post

    Hello Daniel,

    The solution reached me ;-) Nevertheless, the practice in such cases is to open a support ticket and attach the solution there.

    Having that said - your solution uses the RadMenu Classic. Since the installation file that you have is one for the newer version of the controls, namely RadControls for ASP.NET AJAX, I assume that you want to use them...? The skinning of the controls is quite different - the elements differ in CSS class names, so skin files from one version cannot be used with the other. The Telerik Trainer shows development with the ASP.NET AJAX version - I have included a sample project (attached to this post) that you can refer to. Also, you can use the help topics on skin registration and development of custom skins to gain further insight on the skinning process.

    Best wishes,
    Alex
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  8. Daniel
    Daniel avatar
    8 posts
    Member since:
    Oct 2008

    Posted 10 Oct 2008 Link to this post

    Hello Alex,

    Thank you for your help with my post. Letting me know I'm not using what I thought I was prompted me to uninstalled again. This time I removed all Telerik object from my VS toolbar after uninstalling Telerik. I rebooted and installed the Telerik for Ajax again. The tab was created in the VS toolbox for the 'RadContols for ASPNET AJAX Q2 2008' as it has always been doing. It didn't add any controls so I tried to manually add the controls again like last time but this time IT WORKED and all is well. :)

    Thank you again.

    Daniel
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017