RadMenu and RadSiteMap (MegaDropDown) issue in ie9

5 posts, 0 answers
  1. venkat
    venkat avatar
    9 posts
    Member since:
    Apr 2011

    Posted 19 Oct 2011 Link to this post

    Hello,

    I am trying to build MegaDropDown, which is a combination of RadMenu and RadSiteMap and RadSiteMapNodes.
    I have 15 menuitems.Each menuitem has Radsitemap.
    Basically i have to click on the arrow button on the rightmost side of the menu inorder to see the last menu.
    I was able to see Radsitemap for first few menuitems.But if i scrool to the last menuitem and click on the menuitem, i can see the site map
    but , its missing styles for the header in the radsitemap.
    But this is working in firefox and ie8.

    Please see the attachments for more details.
    In WrongStyles.png  "PC Administration" and "Customer Documents" and "Others"   are headings.
    But its missing styles.

    Please Advise.

  2. Shinu
    Shinu avatar
    17571 posts
    Member since:
    Mar 2007

    Posted 19 Oct 2011 Link to this post

    Hello Venkat,

    I am not quite sure about the version you are using and the Generally IE 9 browser is not officially supported by the versions before (starting Q1 2011). I suggest you to upgrade to the latest version.
     Updating RadControls for ASP.NET AJAX to another version or license.

    Thanks,
    Shinu.

  3. venkat
    venkat avatar
    9 posts
    Member since:
    Apr 2011

    Posted 20 Oct 2011 Link to this post

    Hello,

    Thanks for your reply.
    I tried with latest version of the Telerik dll's.Still it didn't work out.
    I am not whether telerik is supporting ie9 officially or not.


    Thanks,

  4. venkat
    venkat avatar
    9 posts
    Member since:
    Apr 2011

    Posted 20 Oct 2011 Link to this post

    Hello,

    While testing the Mega DropDown control, i found out a strange behaviour.
    if i make EnableRootItemScroll="false" then  we can see all radmenuitems .In this scenario there is no need to scroll all the way to the right in order to click on the last radmenuitem.If i click on the last radmenuitem then it is displaying all styles correctly.
    Please find the attachment for reference.

    Please let us know if there is any bug in RadMenu.

    Thanks,
    Prasad

  5. Kate
    Admin
    Kate avatar
    1898 posts
    Member since:
    Sep 2012

    Posted 26 Oct 2011 Link to this post

    Hi Venkat,

    I can not tell for sure if this is a bug of the RadMenu since the scenario that you are implementing is a custom one. Therefore in order to be able to determine what is causing the behavior that you encounter only an image is not enough to replicate the issue. Can you please open a support ticket and send us a simplified runnable project that we could inspect locally and come back to you with a suitable solution?

    Best wishes,
    Kate
    the Telerik team

    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now

Back to Top