RadMap and MultiScaleImage

2 posts, 0 answers
  1. Rieni De Rijke
    Rieni De Rijke avatar
    170 posts
    Member since:
    Mar 2010

    Posted 22 Apr 2013 Link to this post

    We are using RadMap with ILayers as source in one of our InformationLayers. WMS requests (Web Map Services) returns an image witch is binded to the informationlayers source.
    Between version 2012.2 and 2012.3 there is a difference. I can see a new event related to Multiscale image, MultiScaleImage.RaiseMotionFinishedEvent.AnonymousMethod. I don’t know what courses my problems, but if I uses version 2012.2 my program works, and there is no such event.
    The error occurs while using MapZoomBar + and – navigation buttons.
    I start with zoomlevel 18 viewing both MapProvider and the WMS image. Then I push + button in the MapZoomBar. This leads to an http request with an image result. My Image is loading perfectly in zoomlevel 19. When I push – button my MapProvider loads in zoomlevel 18, but there is no WMS image. When I again push + button in the MapZoomBar my image is not loaded anymore in zoomlevel 19. Map center, width and height are not changing.
    If I use the mouse wheel and do the same thing as described, zoom in and out, everything works fine. 

    Is this fixed/changed in Q1 2013 ?

  2. Andrey
    Andrey avatar
    1681 posts

    Posted 24 Apr 2013 Link to this post

    Hi Rieni De Rijke,

    It is very complicated and it is hard to reproduce the problem without your solution, just by using the information that you provided. Could you, please, provide us with your solution or with a small sample solution which reproduces it?

    Andrey Murzov
    the Telerik team

    Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

  3. DevCraft R3 2016 release webinar banner
Back to Top