RadHtmlPlaceholder height 100% on IE8

16 posts, 0 answers
  1. michael albaladejo
    michael albaladejo avatar
    5 posts
    Member since:
    Aug 2009

    Posted 03 Sep 2009 Link to this post

    My silverlight take 100% in height.
    I use RadHtmlPlaceholder to display a PDF.
    The RadHtmlPlaceholder can be visible or collapsed.

    Sometimes when RadHtmlPlaceholder become visible the height of silverlight is reduce.
    There is a white space in the bottom of the page under the control.

    This problem exist only IE8 and not on FireFox 3.

  2. michael albaladejo
    michael albaladejo avatar
    5 posts
    Member since:
    Aug 2009

    Posted 03 Sep 2009 Link to this post

    I inspect the DOM and I see that RadHtmlPlaceholder add an div and in absolute position.
    On IE8 that div has always a height of 384px when RadHtmlPlaceholder become visible.
    If IE window is resized everything is ok.
  3. DevCraft banner
  4. Miroslav
    Admin
    Miroslav avatar
    922 posts

    Posted 03 Sep 2009 Link to this post

    Hello michael,

    Can you try setting the RespectSilverlightLayoutMeasure property to true? This way the html placeholder will be as big as the Silverlight application allows it to be and it may avoid measuring problems that may be the reason for how it renders in your case.

    Best wishes,
    Miroslav
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  5. michael albaladejo
    michael albaladejo avatar
    5 posts
    Member since:
    Aug 2009

    Posted 04 Sep 2009 Link to this post

    Thanks for reply, unfortunatly it does not fix by problem.
  6. Valentin.Stoychev
    Admin
    Valentin.Stoychev avatar
    2198 posts

    Posted 07 Sep 2009 Link to this post

    Hi michael albaladejo,

    Can you send us a project where we can investigate the problem. Thanks in advance!

    Kind regards,
    Valentin.Stoychev
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  7. michael albaladejo
    michael albaladejo avatar
    5 posts
    Member since:
    Aug 2009

    Posted 14 Sep 2009 Link to this post

    I've a test project where you can see the bug but I don't know how to send you this project.

    The bug occurs on IE8 with IE7 compatibility enabled.
  8. Valentin.Stoychev
    Admin
    Valentin.Stoychev avatar
    2198 posts

    Posted 14 Sep 2009 Link to this post

    Hi michael albaladejo,

    You can open a support ticket and attach the project there.

    Sincerely yours,
    Valentin.Stoychev
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  9. Dave
    Dave avatar
    26 posts
    Member since:
    Jun 2009

    Posted 23 Sep 2009 Link to this post

    Was there a resolution to this?  I am having the same issue. Thanks
  10. Valentin.Stoychev
    Admin
    Valentin.Stoychev avatar
    2198 posts

    Posted 24 Sep 2009 Link to this post

    Hi Dave,

    Can you send as a project so we can investigate.

    Thanks!

    Regards,
    Valentin.Stoychev
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  11. Dave
    Dave avatar
    26 posts
    Member since:
    Jun 2009

    Posted 24 Sep 2009 Link to this post

    I don't have something readily available and don't really have time to throw something together.  The issue is a minor annoyance and thought that if there was a quick and easy fix I could do it.
  12. Stefania Iszabela Nagy
    Stefania Iszabela Nagy avatar
    7 posts
    Member since:
    Sep 2009

    Posted 28 Oct 2009 Link to this post

    Hello,

    I have the same problem with my Silverlight application, but it happens in IE6 as well.
    I have tried all the proposed solutions above. Did you per chance happen to solve the problem?
  13. Valentin.Stoychev
    Admin
    Valentin.Stoychev avatar
    2198 posts

    Posted 29 Oct 2009 Link to this post

    Hi Stefania Iszabela Nagy,

    We haven't researched this exact issue, but we made changes to the resizing mechanism of the RadHtmlPlaceholder. Can you try it with the latest Q3 beta2 release.

    Kind regards,
    Valentin.Stoychev
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  14. Stefania Iszabela Nagy
    Stefania Iszabela Nagy avatar
    7 posts
    Member since:
    Sep 2009

    Posted 29 Oct 2009 Link to this post

    Thank you very much for your suggestion.
    I have installed the latest Q3 beta2 release, but now i get an XAML parse error for every Telerik control i use in my project.
    The error is usually signaled on the closing tag line.
    Do you have any idea what could be causing this?
  15. Valentin.Stoychev
    Admin
    Valentin.Stoychev avatar
    2198 posts

    Posted 29 Oct 2009 Link to this post

    Hi Stefania Iszabela Nagy,

    The problem could be that there are different versions of the assemblies referenced. Please check the referenced assemblies. You can try building and entirely new application to see if the problem will be reproduced there too.

    Regards,
    Valentin.Stoychev
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  16. Rashi Patel
    Rashi Patel avatar
    7 posts
    Member since:
    Oct 2009

    Posted 30 Nov 2009 Link to this post

    Hi All,

    I am still able to reproduce the same in IE7 with latest realease downloaded RadControls_for_Silverlight_2009_3_1103_TRIAL_hotfix.

    Can you please help in this?

    Thanks,
    Rashmi Patel
  17. Valentin.Stoychev
    Admin
    Valentin.Stoychev avatar
    2198 posts

    Posted 01 Dec 2009 Link to this post

    Hello Rashi Patel,

    Since this thread become too long can you clarify what is the exact problem you are having. You can also open a new support ticket if you want.

    Greetings,
    Valentin.Stoychev
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
Back to Top
DevCraft banner