radgrid scolling

7 posts, 0 answers
  1. Sylvain
    Sylvain avatar
    3 posts
    Member since:
    Oct 2009

    Posted 04 Nov 2009 Link to this post

    Hello,
     
    I have a radgrid that is paged and i have enabled scrolling, with 3 frozen columns.

    I have three problems:
    1) I would like to disable vertical scrolling. The user of my grid can set the page size to a number of rows and I would like the proper number of rows to be shown, without vertical scrolling. Can this be done?
    2) It seems that the column widths are not scrolled at the same time as the columns are when using horizontal scrolling. By this I mean that when columns are scrolled, the size that they will take is the size of the original column that was showing in that spot before the scrolling took place. This does not look good and reduces the amount of data I can show in the grid at the same time.
    3) As soon as I enabled horizontal scrolling, a number of columns on the right are missing and can't be scrolled to. If I disabled horizontal scrolling then they reappear and I can scroll to them using Internet Explorer's horizontal scroll bar.

    An alternative for me would be to use the default IE scrolling, which fixes problems #1,#2 and #3, but this prevents me from freezing some columns and also the grid displays a vertical line in middle of the column that is at the right of the window.

    Regards,

    Sylvain
  2. Pavlina
    Admin
    Pavlina avatar
    6084 posts

    Posted 04 Nov 2009 Link to this post

    Hello Sylvain,

    In order to render merely the horizontal scroll and avoid the appearance of the vertical scroll, make sure that the height of the records in the grid does not exceed the ClientSettings -> Scrolling -> ScrollHeight scroll setting. 

    When you are using frozen columns you should set fixed widths for your grid columns (through their HeaderStyle -> Width property) or TableLayout = Fixed for the MasterTableView. Note that the default table layout for the grid with scrolling enabled is auto and this may cause the unwanted effect when you enable the frozen columns functionality.
    In order to display all columns when using frozen columns you should increase the Header Style Width of the last column in RadGrid. Thus you should be able to navigate to the leftmost column as expected to see the information in it.

    For more information about frozen columns, please review the following example:
    http://demos.telerik.com/aspnet-ajax-beta/grid/examples/generalfeatures/frozencolumns/defaultcs.aspx

    I hope this information helps.

    Regards,
    Pavlina
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. dot
    dot avatar
    3 posts
    Member since:
    Apr 2009

    Posted 08 Jan 2010 Link to this post

    I have a RadGrid with some frozen columns. I increased the Header Style Width of the last column in RadGrid, to be able to view all the columns. But this does not work all the time.  I am using RadControls for ASP.NET AJAX Q2 2009. I was wondering if this has been fixed in Q3 version.

    Thanks
    shy
  5. Pavlina
    Admin
    Pavlina avatar
    6084 posts

    Posted 11 Jan 2010 Link to this post

    Hi Shylaja,

    The observed problem can occur, depending on the RadGrid width, the columns' widths, and the number of frozen columns. As a workaround, you can try:
    - decreasing the widths of the frozen columns
    - increasing the width of the last column by a large-enough amount, so that it appears
    - increasing the RadGrid width

    Let me know if this helps.

    All the best,
    Pavlina
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  6. dot
    dot avatar
    3 posts
    Member since:
    Apr 2009

    Posted 11 Jan 2010 Link to this post

    Hello Pavlina,

    I appreciate you quick response.

     I already have those workarounds that you list out.  But I have a RadGrid that is dynamic. The number of columns in the RadGrid depends on the result of a query. I have set sufficient header width for the last coulmn of the RadGrid which works for most cases, but sometimes it does not.

    Is adding a dummy column as the last coulmn of the RadGrid, a better solution?

    Thanks
    Shy
  7. Pavlina
    Admin
    Pavlina avatar
    6084 posts

    Posted 12 Jan 2010 Link to this post

    Hi Shylaja,

    In this case we will need more details about your setup. Can you please open a new support ticket and send us a small runnable project where the problem can be reproduced? Thus we could help you further in resolving it.

    All the best,
    Pavlina
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  8. Krsnaraja
    Krsnaraja avatar
    9 posts
    Member since:
    Aug 2007

    Posted 07 Feb 2010 Link to this post

    Disable vertical scrolling

    Instead of correctly setting ClientSettings -> Scrolling -> ScrollHeight, the vertical scroll can be better avoided using CSS style.

    .RadGrid .rgDataDiv  
    {  
        height:100% !important;  

    Thanks,
    Krishna
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017