Rad Filter User Interface is not showing instead it is showing text "And Add ExpressionAdd GroupRemove Item"

5 posts, 0 answers
  1. Puru
    Puru avatar
    17 posts
    Member since:
    Aug 2012

    Posted 16 Jan 2013 Link to this post

    Hi,

    Rad Filter User Interface is not showing instead it is showing text "And  Add ExpressionAdd GroupRemove Item".

    Please help me if any one have also faced this issue, It is very urgent for me.

    Screen Shot is enclosed.

    Thanks
    Puru
  2. Puru
    Puru avatar
    17 posts
    Member since:
    Aug 2012

    Posted 16 Jan 2013 Link to this post

    Any one from telerik?
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Puru
    Puru avatar
    17 posts
    Member since:
    Aug 2012

    Posted 17 Jan 2013 Link to this post

    I am still waiting for any response from telerik team..
  5. William
    William avatar
    2 posts
    Member since:
    Jul 2012

    Posted 10 Jun 2013 Link to this post

    We have built a user control with load/save functionality that wraps the RadFilter control. We're having an identical rendering issue as Puru when this control is inside a tabstrip.

    Markup:
    <telerik:RadAjaxManagerProxy ID="RadAjaxManagerProxy1" runat="server">
           
            <AjaxSettings>
             <telerik:AjaxSetting AjaxControlID="RadFilter1">
                        <UpdatedControls>
                             <telerik:AjaxUpdatedControl ControlID="RadFilter1" />
                              
                        </UpdatedControls>
                   </telerik:AjaxSetting>
                 <telerik:AjaxSetting AjaxControlID="chk_FILTER_IS_PUBLIC">
                    <UpdatedControls>
                        <telerik:AjaxUpdatedControl ControlID="chk_FILTER_IS_PUBLIC" />               
                    </UpdatedControls>
                </telerik:AjaxSetting>
                <telerik:AjaxSetting AjaxControlID="btnSaveFilter">
                    <UpdatedControls>
                        <telerik:AjaxUpdatedControl ControlID="btnSaveFilter" />
                        <telerik:AjaxUpdatedControl ControlID="ddl_FilterList" />
                        <telerik:AjaxUpdatedControl ControlID="txt_FILTER_NAME" />
                        <telerik:AjaxUpdatedControl ControlID="chk_FILTER_IS_PUBLIC" />
                         
                    </UpdatedControls>
                </telerik:AjaxSetting>
                <telerik:AjaxSetting AjaxControlID="btnLoadFilter">
                    <UpdatedControls>
                        <telerik:AjaxUpdatedControl ControlID="RadFilter1"></telerik:AjaxUpdatedControl>
                        <telerik:AjaxUpdatedControl ControlID="btnLoadFilter" />               
                    </UpdatedControls>
                </telerik:AjaxSetting>
                <telerik:AjaxSetting AjaxControlID="btnDeleteFilter">
                    <UpdatedControls>
                        <telerik:AjaxUpdatedControl ControlID="btnDeleteFilter" />
                        <telerik:AjaxUpdatedControl ControlID="ddl_FilterList" />               
                    </UpdatedControls>
                </telerik:AjaxSetting>
            </AjaxSettings>
        </telerik:RadAjaxManagerProxy>
    <%--
    <asp:Panel runat="server" ID="pUSER_FILTERS" GroupingText="User Filters Control"
        Width="1240px" Visible="True">--%>
        <table width="1240">
            <tr>
                <td align="left" valign="top" style="width: 200px">
                    <asp:Label ID="Label1" runat="server" Text="Select User Filter Options:"></asp:Label>
                </td>
                <td align="left" valign="top" style="width: 200px">
                    <telerik:RadFilter runat="server" ID="RadFilter1" ShowApplyButton="true" SettingsFormatter="BinaryFormatter"
                        >
                    </telerik:RadFilter>
                </td>
                <td align="left" valign="top" style="width: 400px">
                    <telerik:RadTextBox ID="txt_FILTER_NAME" runat="server" DisplayText="Filter Name"
                        Style="float: left">
                    </telerik:RadTextBox>
                    <telerik:RadButton ID="btnSaveFilter" runat="server" Text="Save Filter" Style="float: left">
                    </telerik:RadButton>
                    <asp:CheckBox ID="chk_FILTER_IS_PUBLIC" runat="server" AutoPostBack="true" Text="Check to make filter public"
                        Style="float: left" />
                </td>
                <td align="left" valign="top" style="width: 400px">
                    <telerik:RadComboBox ID="ddl_FilterList" runat="server" Style="float: left">
                    </telerik:RadComboBox>
                    <telerik:RadButton ID="btnLoadFilter" runat="server" Text="Load Filter" Style="float: left">
                    </telerik:RadButton>
                    <telerik:RadButton ID="btnDeleteFilter" runat="server" Text="Delete Selected Filter"
                        Style="float: left" OnClientClick="if(!confirm('Are you sure you want to delete this Filter?')) return false;">
                    </telerik:RadButton>
                </td>
            </tr>
        </table>

  6. William
    William avatar
    2 posts
    Member since:
    Jul 2012

    Posted 11 Jun 2013 Link to this post

    I was able to resolve my issue by changing a setting on my master page's RadStyleSheetManager. After disabling the Telerik CDN, the problem disappeared. Here's what my StyleSheetManager markup looks like:

    <telerik:RadStyleSheetManager ID="RadStyleSheetManager1" runat="server" EnableStyleSheetCombine="True"  CdnSettings-TelerikCdn="Disabled">
        </telerik:RadStyleSheetManager>


Back to Top
UI for ASP.NET Ajax is Ready for VS 2017