Q3 Upgrade - Very Undesired Behavior Change in RadTileView

7 posts, 0 answers
  1. Kathleen
    Kathleen avatar
    55 posts
    Member since:
    Jun 2009

    Posted 08 Dec 2010 Link to this post

    I am in the process of upgrading our solution to Q3.  I have worked out most of the breaking changes from RadGridView but I have one remaining item that is broken that I'm not sure how to deal with.

    When I open a RadTileItem on an empty RadTileView, it opens and displays very small, then pop expands to the full size once the related data bound on the controls is loaded.

    This was not the behavior prior to the upgrade where the RadTileItem filled the available space.

    I am attaching 2 screen shots, one revealing the 'loading' change and one revealing the expected.

    I can't proceed with the upgrade till I resolve this new issue.

    Thanks

    Kathleen
  2. Zarko
    Admin
    Zarko avatar
    755 posts

    Posted 10 Dec 2010 Link to this post

    Hi Kathleen,

     We are aware of this problem and it'll be fixed for the Q1 2011 Beta which is scheduled for the middle of January.
    Unfortunately there's no work around that we can give you for the moment.

    Regards,
    Zarko
    the Telerik team
    Browse the videos here>> to help you get started with RadControls for Silverlight
  3. DevCraft banner
  4. Kathleen
    Kathleen avatar
    55 posts
    Member since:
    Jun 2009

    Posted 21 Dec 2010 Link to this post

    Is there a tracking # for this issue? Is it in any of the more recent internal builds?  Its preventing me from being able to obtain other fixes.
  5. Zarko
    Admin
    Zarko avatar
    755 posts

    Posted 21 Dec 2010 Link to this post

    Hi Kathleen,

    Currently we are making a major refactoring on the RadTileView which should be ready for the Q1 Beta and this bug will be fixed with it.
    If you have further questions feel free to ask.

    Greetings,
    Zarko
    the Telerik team
    Browse the videos here>> to help you get started with RadControls for Silverlight
  6. Kathleen
    Kathleen avatar
    55 posts
    Member since:
    Jun 2009

    Posted 27 Jan 2011 Link to this post

    I downloaded the January 14th Release and this is still an issue, any update or possible work around?
  7. Zarko
    Admin
    Zarko avatar
    755 posts

    Posted 28 Jan 2011 Link to this post

    Hello Kathleen,

     I'm sorry to inform you that the Q1 2011 Beta was postponed for the end of February and we still don't know of a work around for this issue.

    Regards,
    Zarko
    the Telerik team
    Let us know about your Windows Phone 7 application built with RadControls and we will help you promote it. Learn more>>
  8. Kathleen
    Kathleen avatar
    55 posts
    Member since:
    Jun 2009

    Posted 28 Jan 2011 Link to this post

    Thanks.  I worked around it by setting the control to maximize before displaying it, for now this seems to get past the initial issue until the problems resolved.
Back to Top
DevCraft banner