Q2 2010 - Textbox decorator problem in IE7/8

2 posts, 0 answers
  1. Georg
    Georg avatar
    12 posts
    Member since:
    Nov 2009

    Posted 04 Sep 2010 Link to this post

    Hi,
    i spent some time to see why this bug happens and i put together a small example. Perhaps you should do something about it.
    I atttached a snapshot of a simple textbox that breaks to the 100% width of the container it resides on if you hapen to use "table { width:100% }" inside a css file.

    Here is the code:

     

    <head runat="server">
        <title></title>
        <style type="text/css">
            table { width:100%; }
        </style>    
        <style type="text/css">
            *html .rfdDecorated, 
            *html a.rfdSkinnedButton,
            {
                vertical-align: top !important;
            }
            *+html .rfdDecorated, 
            *+html a.rfdSkinnedButton
                
            {
                vertical-align: top !important;
            }
        </style>
    </head>
    <body style="background-color:#fff;">
        <form id="form1" runat="server">
            <telerik:RadScriptManager ID="ScriptManager" runat="server" />
            <telerik:RadFormDecorator ID="FormDecorator1" runat="server" DecoratedControls="All" />
            <telerik:RadSkinManager ID="RadSkinManager1" runat="server" ShowChooser="false" Skin="Black" PersistenceMode="Cookie">
            </telerik:RadSkinManager>
            <table style="width:100%; height:200px;" border="1">
                <tr>
                    <td>
                        <asp:TextBox ID="TextBox1" runat="server" style="width:200px;" />                
                    </td>
                </tr>
            </table>
        </form>
    </body>
    </html>

     

    Thank you.

     

     

     

     

     

  2. Fiko
    Admin
    Fiko avatar
    1406 posts

    Posted 09 Sep 2010 Link to this post

    Hi George,

    In IE browsers RadFormdecorator uses a table in order to show rounded corners. This is why the global setting for the tables:
    table
    {
        width: 100%;
    }
    breaks the RadFirmDecorator's behavior. In your case you need to remove this global setting or add another one which will override it in order to set width:auto for the table used in the decorator:
    table.rfdRoundedWrapper
    {
        width: auto;
    }


    I hope this helps.

    All the best,
    Fiko
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. UI for ASP.NET Ajax is Ready for VS 2017
Back to Top