Q2 2010 Bug with GUID Report Parameters

3 posts, 0 answers
  1. Rich
    Rich avatar
    20 posts
    Member since:
    Feb 2004

    Posted 05 Sep 2010 Link to this post

    I have reports that worked perfect in the Q2 2009 release and when I upgraded them, all my sub-report parameters that are bound to GUID fields in the parent report no longer work . They give an error saying they have an invalid value for the parameter.

    Since the report parameters do not accept GUID types, I was receiving them as string type which worked perfectly before by converting the field value to a string before passing it. Now, it just errors out and I have to specifically have in my data set the GUID converted to a string before binding the parameter to the field in the dataset.

    This is really disappointing that I now have to hack a fix into all these reports to make this work.
  2. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 06 Sep 2010 Link to this post

    Hi Richard,

    Since Telerik Reporting Q1 2010 version, when the report enters the processing stage, report parameter values are validated against their validation properties (no matter if the parameter is visible or not). If one or more parameters do not have valid values, processing is aborted.

    The validation properties include the type of the parameter, is it a single or multi-value, is its value among the available values (if such are defined), is null value allowed etc...

    Although we're not sure of your exact scenario, you should be able to convert the guid to string in the subreport parameter expression directly by using the CStr() built-in function, thus avoiding changes in your database.

    Regards,
    Steve
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. DevCraft banner
  4. Rich
    Rich avatar
    20 posts
    Member since:
    Feb 2004

    Posted 06 Sep 2010 Link to this post

    If you changed it to strong type checking, then you should have expanded your types allowed for report parameters. Especially to include Guid (uniqueidentifier) types as they are often used as keys in databases.

    We are in the process of taking care of the problem via conversion, but this could have been easily avoided and solved much better by expanding your types as I just suggested.
Back to Top