Problem with IPad and checkboxes

12 posts, 1 answers
  1. Andreas
    Andreas avatar
    137 posts
    Member since:
    May 2008

    Posted 04 Jul 2012 Link to this post

    Hi,

    Seems to work a little bit randomly when using checkboxes in the treeview when using Ipad.
    Sometimes they get checked and sometimes they don't...
    Even in your demo:
    http://demos.telerik.com/aspnet-ajax/treeview/examples/functionality/checkboxes/defaultcs.aspx

    Regards
    Caesar
  2. Answer
    Ivan Zhekov
    Admin
    Ivan Zhekov avatar
    539 posts

    Posted 05 Jul 2012 Link to this post

    Hi, Andreas.

    We are working on mobile improvements this and the TreeView control will receive some updates, among them this feature.

    Regards,
    Ivan Zhekov
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. John
    John avatar
    19 posts
    Member since:
    Sep 2011

    Posted 01 Oct 2012 Link to this post

    Can anyone provide a timeline on this issue?  Will this be out in Q3 2012 or later?
    Thanks
    John
  5. Plamen
    Admin
    Plamen avatar
    2730 posts

    Posted 03 Oct 2012 Link to this post

    Hi John,

     
    The issue with the Checkboxes in IPad appeared to be more complicated than we expected and unfortunately will not be able to fix it for Q3. Nevertheless we will make our best to fix it in a short period after that but unfortunately we can not commit on any ETA.

    Please excuse us for this limitation of our control and for the inconveniences caused by it.

    Greetings,
    Plamen
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  6. Paul Desormeaux
    Paul Desormeaux avatar
    11 posts
    Member since:
    Jun 2010

    Posted 21 Apr 2013 Link to this post

    Can we have an updated ETA for this.

    Quite critical for our development team.

    Than you.

    Paul
  7. Paul Desormeaux
    Paul Desormeaux avatar
    11 posts
    Member since:
    Jun 2010

    Posted 21 Apr 2013 Link to this post

    Specifically we are having problems with a RadListBox - Checkbox = True.
    The checkmark appears for a moment ( i.e. 0.5 sec )and then disappear right after checking it.
    The state is indeed checked - but visually it is unchecked. Not so good ...

    Thx.
  8. Plamen
    Admin
    Plamen avatar
    2730 posts

    Posted 24 Apr 2013 Link to this post

    Hello Paul,

     
    I have inspected the issue you have described on our on-line demo but could not observe any unusual behavior. Would you please elaborate if we have to add something to the mark up or if you are using other than the latest version of RadControls so we could inspect the issue deeper.

    Regards,
    Plamen
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  9. Paul Desormeaux
    Paul Desormeaux avatar
    11 posts
    Member since:
    Jun 2010

    Posted 24 Apr 2013 Link to this post

    Thank you for your reply.

    I am using the latest version : 2013.1.417.35.

    I think I understand the issue now : Both the Telerik ListBox Checkboxes demo and my application work ok on the iPad
    if you touch the checkbox for a long enough period of time ( i.e. 0.5 seconds ).

    Could it be that there is client-side processing taking place by Telerik on checking a RadListBox checkbox that slows down checking in this manner?

    It may get slightly slower when the RadListBox checkbox list is longer - not sure ...

    Is there anything that could be done to speed up the checking process ?

    Thank you.

    Paul
  10. Plamen
    Admin
    Plamen avatar
    2730 posts

    Posted 25 Apr 2013 Link to this post

    Hello Paul,

     
    I have inspected the issue once again and the checkboxes were checked immediately I tapped on them. Would you please elaborate of there is anything specific that you for in order to observe the unusual behavior because it is not quite clear so far?

    Regards,
    Plamen
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  11. Paul Desormeaux
    Paul Desormeaux avatar
    11 posts
    Member since:
    Jun 2010

    Posted 25 Apr 2013 Link to this post

    When I check on any Telerick RadListBox checkbox on an iPad I have to do so for ~ 0.5 sec - 0.75 sec.
    Which makese it quite slow for checking multiple checkboxes.
    And also confused people when they think they have clicked on a checkbox - but it is not registered as such ...

    Specifically, if I just quickly touch a RadListBox checkbox, the checkmark is not accepted.
    I have to hold my finger there for a short while ( 0.5 sec ).

    This is the same with the telerik Demo or my website application.

    Perhaps Telerik is doing 'debouncing' ?

    Thank you.
  12. Plamen
    Admin
    Plamen avatar
    2730 posts

    Posted 26 Apr 2013 Link to this post

    Hello Paul,

     
    We have inspected the issue you described deeper and it seems to be caused by the devices themselves (IPad in your case) -they are making a 0,1-0,5 seconds delayed response by default (d because of the unwanted touches).

    Hope this will explain the issue.

    Kind regards,
    Plamen
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  13. Paul Desormeaux
    Paul Desormeaux avatar
    11 posts
    Member since:
    Jun 2010

    Posted 26 Apr 2013 Link to this post

    Thank you for your response.

    I think & hope this information could very well be useful to others.

    Thank you.

    Paul
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017