problem changing the language in RadEditor

10 posts, 0 answers
  1. Cecilia
    Cecilia avatar
    10 posts
    Member since:
    Nov 2007

    Posted 11 May 2008 Link to this post

    Hi
    I have a problem changing the language in RadEditor.
    I want all the menus and  the spellchecker to have another language than default.

    The language-file (tdf) is in the right folder and the spellcheck file aswell.

    How can I get the Editor to be in my language? In which files do I have to make changes in the code?

    I tried to add Language="" in the pagelayout, but it didn't work.

    Thanks!
    Regards Cecilia
  2. Rumen
    Admin
    Rumen avatar
    12851 posts

    Posted 12 May 2008 Link to this post

    Hi Cecilia,

    Could you please open the  \Program Files\Common Files\Microsoft Shared\web server extensions\wpresources\RadEditorSharePoint\x.x.x.x__xxxxxxx\Resources\ConfigFile.xml and ListConfigFile.xml files and put the following tag in them:

    <property name="Language">fr-FR</property>

    Save the files and restart your browser.


    Best regards,
    Rumen
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center

  3. Cecilia
    Cecilia avatar
    10 posts
    Member since:
    Nov 2007

    Posted 12 May 2008 Link to this post

    Hi!

    Thank you, that helped me get the buttons in the correct language.

    How can I get the AjaxSpellCheck to check the right language?
    The Localization is alright and the .tdf-file aswell.

    When I push the spellcheck button I get a message "undefined"

    Regards
    Cecilia
  4. Rumen
    Admin
    Rumen avatar
    12851 posts

    Posted 12 May 2008 Link to this post

    Hi Cecilia,

    Please, note that the Lite version of RadEditor for MOSS does not support the inline AJAX spellchecker.

    If you use the fully functional Premium version of RadEditor for MOSS then you can set the desired dictionary language of the AjaxSpellCheck by adding the SpellDictionaryLanguage tag in the ConfigFile.xml and ListConfigFile.xml files

      <property name="SpellDictionaryLanguage">fr-FR</property>

    Best regards,
    Rumen
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  5. Cecilia
    Cecilia avatar
    10 posts
    Member since:
    Nov 2007

    Posted 13 May 2008 Link to this post

    Yes, that worked, thank you!

    How can i change the language of the buttons: "finish spellchecking" and "cancel" and in the menus for adding new words to the dictionary etc.

    Regards Cecilia
  6. Rumen
    Admin
    Rumen avatar
    12851 posts

    Posted 14 May 2008 Link to this post

    Hi Cecilia,

    By setting the Language property of RadEditor to some language string, this will localize the integrated inline AjaxSpellCheck-er too. You can see the following live example for more information: Localization.

    Best regards,
    Rumen
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  7. Cecilia
    Cecilia avatar
    10 posts
    Member since:
    Nov 2007

    Posted 19 May 2008 Link to this post

    Hi!

    I looked at the live example and it looks good. The problem is that my radeditor doesn't work. Instead of saying "spellcheckning mode" in Swedish  it says undefined. The buttons are also in English, "Finish spellcheckning" and "cancel".

    I have these tags in the ConfigFile.xml and the ListConfigFile.xml:
      <property name="Language">sv-SE</property>
      <property name="SpellDictionaryLanguage">sv-SE</property>

    How can I get the spellchecker to work in Swedish?

    Thanks!
    Regards Cecilia
  8. Rumen
    Admin
    Rumen avatar
    12851 posts

    Posted 19 May 2008 Link to this post

    Hi Cecilia,

    Do you have Swedish (sv-SE) up-to-date localization for RadEditor? The sv-SE.zip localization which you can download from our site is made by a customer and it is for version 6.x of RadEditor Classic. We introduced the inline Ajax spellchecker in version 7.x and that is why the localization strings for the AjaxSpellChecker in the sv-SE localization are missing.

    Here are the localization strings that you need to put in the Main.xml file of the sv-SE localization

    <string id="SpellCheckEnd">Finish spellchecking</string>
    <string id="SpellCheckComplete">Spellchecking complete!</string>
    <string id="SpellingChange">Spelling Change</string>
    <string id="NoSuggestions">(no suggestions)</string>
    <string id="ChangeWordString">Change Manually</string>
    <string id="IgnoreAllString">Ignore All</string>
    <string id="IgnoreString">Ignore</string>
    <string id="MoreThanOnceMessage">This word occurs more than once in the text. Would you like to replace all instances?</string>
    <string id="UndoDisabledMessage">You cannot undo further while in spellcheck mode. Please finish spellchecking first.</string>
    <string id="AddToDictionary">Add to dictionary</string>

    <string id="AddCustomWordSuccess">successfully added to dictionary</string>
    <string id="SpellingInProgress">Spell checking in progress...</string>
    <string id="SpellingMode">Spell checking mode. Misspelled words are with yellow background.</string>
    <string id="NoSpellingMistakes">No mistakes found.</string>

    Greetings,
    Rumen
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  9. Cecilia
    Cecilia avatar
    10 posts
    Member since:
    Nov 2007

    Posted 20 May 2008 Link to this post

    Hi!

    Thank you that worked!

    But the buttons "finish spellcheckning" and "cancel" are still in english.
    Where can I change that?

    Thanks
    Regards Cecilia
  10. Rumen
    Admin
    Rumen avatar
    12851 posts

    Posted 20 May 2008 Link to this post

    Hi Cecilia,

    After adding the localization tags in the main.xml file you should translate the localization strings inside the string tags:

    <string id="SpellCheckEnd">put your localization here[Finish spellchecking]</string>
    <string id="Cancel">put your localization here[Cancel]</string>

    The string tag with id="Cancel" will localize the cancel button.

    Localize the red strings, save the file and test the spellchecker.

    Kind Regards,
    Rumen
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
Back to Top