Problem Ajaxifying the RadPanelBar in 2009.2 826

1 posts, 0 answers
  1. stiz0r
    stiz0r avatar
    1 posts
    Member since:
    Sep 2009

    Posted 22 Sep 2009 Link to this post

    Hello!

    We just upgraded from what I believe was 2009.1.422.20 to the newest; 2009.2 826.20
    Each panelbar we use only have one item with one item with content. The content is fetched with a postback if the panelbar was currently closed. We use an RadAjaxPanel around the RadPanelBar which displays a loading panel, when the user clicks the panelbar. Once the user clicked the panelbar it opened with a height of minimum 40pixels and the resized itself to the full height it needed. This means the loadingpanel was displayed over both the "bar" itself and the content window. 

    This worked perfectly in the latest version we used, but when we upgraded to the newest version, the loading panel is only displayed inside the "bar", and the content window displays nothing until the content is ready.

    We have a created a custom style for the panelbar which was created for the Q1 version.
    The problem is mostly IE related, it works sufficiently in FF and Chrome.

    This shows the Q1 working version, which "ajaxifies" the whole Panelbar with content
    http://img8.imageshack.us/i/correctp.png/

    This shows the newest version 2009.2 826, which only displays the loadingpanel inside the "bar"
    http://img8.imageshack.us/i/wrongrh.png/

    I know you will probably tell me to create a ticket, but it will be some work for us to create a project with everything working. So I was hoping you had some tips based on my description. If not, I will try to provide one..

    If anything is unclear, do not hesitate to ask me to clarify.

    Thank you!

    Ps. happy Independence day!
Back to Top