Pane close button with Windows 7 theme

4 posts, 0 answers
  1. Patrick
    Patrick avatar
    372 posts
    Member since:
    Aug 2012

    Posted 22 Jan 2014 Link to this post

    Hello,
    there is a little problem with the pane close button template in the Windows 7 theme: you need to move the mouse cursor to the black part on the x in the button for the button to be active. When the button is active, it remains active if the mouse cursor is moved outside the x. It seems that the backgroud of the "not active" state should be set to Transparent and not to null.
    Note that the same problem appears with the Office Blue theme, but not on the Office 2013 theme. I have not checked the other themes.
    Patrick
  2. Kalin
    Admin
    Kalin avatar
    1207 posts

    Posted 24 Jan 2014 Link to this post

    Hello Patrick,

    We were not able to reproduce the described issue. I tested the scenario with the latest version of the controls (Q3 2013 SP 1) with Pane docked inside and outside of the DocumentHost and floating Pane. I'm attaching a video of my tests. Please check it let me know if I am missing anything here, I'll ask you to also share some more information about your setup and the version of the controls you are using.

    I'm looking forward to your reply.

    Regards,
    Kalin
    Telerik
    TRY TELERIK'S NEWEST PRODUCT - EQATEC APPLICATION ANALYTICS for SILVERLIGHT.
    Learn what features your users use (or don't use) in your application. Know your audience. Target it better. Develop wisely.
    Sign up for Free application insights >>
  3. DevCraft banner
  4. Patrick
    Patrick avatar
    372 posts
    Member since:
    Aug 2012

    Posted 24 Jan 2014 Link to this post

    Hello Kalin,
    I have something slightly different in my setup: the CloseButtonPosition property of the RadDocking control is set to InPane. When I move the mouse cursor slowly on the x, the button is not active until I "touch" th black part of the x.
    Patrick
  5. Kalin
    Admin
    Kalin avatar
    1207 posts

    Posted 27 Jan 2014 Link to this post

    Hello Patrick,

    Thanks for the explanation, we managed to reproduce the described issue and I logged it in our Feedback portal. You can easily track its status on the following link:
    http://feedback.telerik.com/Project/143/Feedback/Details/101742-when-the-closebuttonposition-is-set-to-inpane-the-close-button-cannot-be-clicked

    I'm sorry for any inconvenience caused. I have updated your Telerik points for your involvement as well.

    Regards,
    Kalin
    Telerik
    TRY TELERIK'S NEWEST PRODUCT - EQATEC APPLICATION ANALYTICS for SILVERLIGHT.
    Learn what features your users use (or don't use) in your application. Know your audience. Target it better. Develop wisely.
    Sign up for Free application insights >>
Back to Top