OverflowBehavior in Firefox

13 posts, 0 answers
  1. Irina
    Irina avatar
    20 posts
    Member since:
    Sep 2007

    Posted 30 Oct 2007 Link to this post

    Hi. I am using a Rad Scheduler with OverflowBehavior set to Scroll and I have set the height to 100%. Also I set the height of html, body and form to 100%.
    Everything is ok in IE6 and IE7, but in Firefox I get a scrollbar, the scheduler is just showing the height for the first hour.
    OverflowBehavior="Scroll" Height="100%".




  2. Peter
    Admin
    Peter avatar
    6637 posts

    Posted 30 Oct 2007 Link to this post

    Hi Irina,

    If a scrollbar is undesirable you should set OverflowBehavior="Expand". I tested RadScheduler with both possible values for OverflowBehavior and I got consistent behavior for IE and FF. If you have a live url or an isolated project which exhibits the problem, please, share it with us so we can test it locally.



    All the best,
    Peter
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Shaun Peet
    Shaun Peet avatar
    571 posts
    Member since:
    Aug 2004

    Posted 22 Jan 2008 Link to this post

    I have the scheduler inside a RadPane and am experiencing the exact same behaviour as described by Irina.  Live url:

    http://www.mycal.ca

    I'm hoping that this issue has been addressed since then.
  5. Irina
    Irina avatar
    20 posts
    Member since:
    Sep 2007

    Posted 23 Jan 2008 Link to this post

    Hi. I didn't solve my problem... to make it work temporarily I put a fixed height, so Firefox doesn't show the height only for the first hour. But idealy I would like to use a 100% height.

    Irina.
  6. Peter
    Admin
    Peter avatar
    6637 posts

    Posted 23 Jan 2008 Link to this post

    Hi,

    Shaun, thank you for sending a live url. We examined it and discovered that the problem is caused by that the scheduler is nested within <span> ... </span> tags. We have replied in greater detail to the email you sent about the same issue.

    Irina, we are not sure what is causing the problem at your side. Do you have a live url which we can test?


    Kind regards,
    Peter
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  7. Irina
    Irina avatar
    20 posts
    Member since:
    Sep 2007

    Posted 23 Jan 2008 Link to this post

    Hi. I don't have a live url, but I build a simple test page and the behaviour for Firefox is the same. This would be the page:

    <%

    @ Page Language="C#" AutoEventWireup="true" CodeBehind="Default.aspx.cs" Inherits="SchedulerHeight._Default" %>
    <%
    @ Register Assembly="Telerik.Web.UI" Namespace="Telerik.Web.UI" TagPrefix="telerik" %>
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

    <

    html xmlns="http://www.w3.org/1999/xhtml" style="height:100%">

    <
    head runat="server">
    <title>Test</title>
    </
    head>

    <

    body style="height:100%; margin:0px;" scroll="no">
    <form id="form1" runat="server" style="height:100%">
    <asp:ScriptManager ID="ScriptManager1" runat="server" />
    <div>

    <telerik:RadScheduler ID="RadScheduler1" runat="server" Height="100%" SelectedView="WeekView"  DayEndTime="20:00:00"  DayStartTime="07:00:00" DataStartField="Start" DataEndField="Finish"  DataKeyField="BookingItemId" DataSubjectField="BookingReferenceNumber"  FirstDayOfWeek="Monday" LastDayOfWeek="Sunday">
    </telerik:RadScheduler>

    </div>
    </form>
    </
    body>
    </
    html>

    I can see that ok for IE6 and 7, but for Firefox I only see the height for the first hour. If I put a fixed size for the height, so instead of 100% I put 400px for the scheduler's height, everything is ok in Firefox too.

    Thank you,
    Irina.
  8. Peter
    Admin
    Peter avatar
    6637 posts

    Posted 23 Jan 2008 Link to this post

    Hello Irina,

    With the provided settings, it is expected that RadScheduler will not span over the entire height of the window. The container in which RadScheduler resides should have fixed height. For example, try the following:
     <div style="height:600px">  
            <telerik:RadScheduler ID="RadScheduler1" runat="server" 

    I hope this helps.


    Regards,
    Peter
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  9. Shaun Peet
    Shaun Peet avatar
    571 posts
    Member since:
    Aug 2004

    Posted 23 Jan 2008 Link to this post

    Hi Peter,

    I can't find your reply anywhere.  Where should I be looking for it?
  10. Peter
    Admin
    Peter avatar
    6637 posts

    Posted 24 Jan 2008 Link to this post

    Hi Shaun,

    I apologize for the misunderstanding. It looks like we haven't sent you an email explaining the cause of the problem.

    Anyhow, the problem occurs because RadScheduler is nested in <span> </span> tags. Please, remove these tags or replace them with div.

    I hope this helps.


    Greetings,
    Peter
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  11. Irina
    Irina avatar
    20 posts
    Member since:
    Sep 2007

    Posted 24 Jan 2008 Link to this post

    Hello Peter.
    That helped me. Thank you very much.

    Irina.
  12. Shaun Peet
    Shaun Peet avatar
    571 posts
    Member since:
    Aug 2004

    Posted 24 Jan 2008 Link to this post

    Hi Peter,

    I changed the asp:updatepanel (which is the container for the scheduler) RenderMode from Inline back to the default "Block", which essentially changed the span tag to a div tag.  Unfortunately, this had no effect.  Any other ideas?
  13. Atanas Korchev
    Admin
    Atanas Korchev avatar
    8462 posts

    Posted 25 Jan 2008 Link to this post

    Hi Shaun Peet,

    It seems the container's height needs to be 100% as well. Please add the following CSS to your page:
     
    <style type="text/css">
    #upScheduler
    {
        height: 100%;
    }
    </style>

    Regards,
    Albert
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  14. Shaun Peet
    Shaun Peet avatar
    571 posts
    Member since:
    Aug 2004

    Posted 25 Jan 2008 Link to this post

    I added the css rule to the stylesheet and it works now.  Thanks.

    FYI, in our area our web stats show that about 95% of our visitors use Internet Explorer - and about 55% of those are using version 6.
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017