OS X browsers see blank page when entering a site with Telerik.Web.UI.Skins.Window.css

3 posts, 0 answers
  1. Zeev
    Zeev avatar
    9 posts
    Member since:
    Feb 2013

    Posted 15 Dec 2013 Link to this post

    I have a very small and limited ASP.NET site where i use telerik controls and skins.
    The site works fine with all browsers running from Windows, however, many of the MAC OS X users claim that when they reach our site all they can see is a blank white page.
    I don't have any css files other than 1 BlackMetroSkin on the entire site.
    I couldn't find anything on the forums or google regarding such an issue,
    Please assist.
  2. Danail Vasilev
    Danail Vasilev avatar
    1476 posts

    Posted 18 Dec 2013 Link to this post

    Hi Zeev,

    We are not aware of such issues with RadControls in browsers opened under MAC OS. It may be possible that there are some JavaScript errors on your page that break the proper functionality and appearance of the script controls on the page. If there are such errors they must be found and fixed.

    Can you confirm that all the requests executed by the page are successful? If there are requests which are not successful they could prevent control's scripts and styles from loading. If that is the case you can try
    • Toggling the state of the CDN(turning it on/off)
    • Clearing the cache of the browser/ASP server on which you are running the page.
    • Use Fiddler or FireBug to see which requests are failing and why. You can also examine briefly Web Resources Troubleshooting help article and use the provided solutions, in case similar issues are present.

    Can you also confirm whether the issue is browser specific (if so which is the browser and its version) or it occurs in most major browsers like FireFox, Chrome and Safari?

    If the above steps are not helpful could you please try to send us a fully runnable sample with reproduction steps of the issue, so that we can make an investigation locally?

    Danail Vasilev
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to the blog feed now.
  3. DevCraft R3 2016 release webinar banner
  4. Zeev
    Zeev avatar
    9 posts
    Member since:
    Feb 2013

    Posted 18 Dec 2013 Link to this post

    thanks for the support.
    the problem was with the Certificate my site had, it had nothing to do with you.
    Apparently OS X has issues with certificates with higher keys than 1024.

    You can close this thread.
Back to Top