Oledb error

5 posts, 0 answers
  1. Magnus
    Magnus avatar
    4 posts
    Member since:
    Jun 2013

    Posted 02 Feb 2015 Link to this post

    Hi

    I am trying to connect to Osisoft PI through Oledb but get "Index was outside the bounds of the array" message that prevents me from making the connection. I'm using the 32-bit Report designer and 32-bit oledb on 64-bit Windows.

    Any ideas? Is there any way I can get more details about the error?
  2. Hinata
    Hinata avatar
    146 posts
    Member since:
    Dec 2013

    Posted 04 Feb 2015 in reply to Magnus Link to this post

    Hi Magnus,

    Can you share the whole select statement?
    Also check if it is specific to this select statement text, or the error is shown regardless of what you write in the select statement box.
  3. DevCraft banner
  4. Magnus
    Magnus avatar
    4 posts
    Member since:
    Jun 2013

    Posted 04 Feb 2015 in reply to Hinata Link to this post

    Thanks for your reply, Hardik.

    It is regardless of what I write. The exact same statement works in an other Reporting tool. 
  5. Hinata
    Hinata avatar
    146 posts
    Member since:
    Dec 2013

    Posted 09 Feb 2015 in reply to Magnus Link to this post

    Hi Magnus,

    Can you describe some way or steps to test this?
    Note that eventually support for OLE DB will be dropped: Microsoft is Aligning with ODBC for Native Relational Data Access.
    The article also mentions that ODBC is better than OLE DB, so you might want to try that as well in order to get the work done.
  6. Paul
    Paul avatar
    1 posts
    Member since:
    Jun 2014

    Posted 11 Jan Link to this post

    PI-ODBC sql and configuration can be very touchy. I am working on a similar task. Can you share your <ConnectionString> entry made for the PI instance?
Back to Top
DevCraft banner