Object Expected error with RadComboBox and updatepanel in second postback.

2 posts, 0 answers
  1. jai
    jai avatar
    16 posts
    Member since:
    Jan 2008

    Posted 06 Sep 2010 Link to this post

    Hi,

    Im using Telerik 2010.2.713 version with Sharepoint 2010.
    Created visualwebpart with simple button, 1 radcombobox inside updatepanel, initially the radcombobox will be visible false, on button click we are trying to enable the radcombobox.
    But when i click on button im getting error on page 'Telerik is undefined', so i changed my web.config with Telerik.Web.UI.WebResource in <handlers>, later on im getting 'Object expected'.

    Please find the below code that im using

    visual webpart usercontrol

    <asp:UpdatePanel runat="server" ID="updatePanel1" UpdateMode="Conditional" >
        <ContentTemplate>
            <asp:Button runat="server" ID="btn1" Text="ShowButton" OnClick="btn1_Click" />
            <telerik:RadComboBox visible="false" AutoPostBack="true" ID="RadComboBox1" runat="server">
                <Items>
                    <telerik:RadComboBoxItem Text="1" />
                    <telerik:RadComboBoxItem Text="2" />
                    <telerik:RadComboBoxItem Text="3" />
                </Items>
            </telerik:RadComboBox>
        </ContentTemplate>
    </asp:UpdatePanel>

    Telerik references in Web.Config

    <httpHandlers>
          <remove verb="*" path="*.asmx" />
          <add verb="*" path="*.asmx" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
          <add verb="*" path="*_AppService.axd" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
          <add verb="GET,HEAD" path="ScriptResource.axd" validate="false" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
          <add path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" verb="*" validate="false" />
        </httpHandlers>

    <handlers>
          <remove name="OPTIONSVerbHandler" />
          <remove name="WebServiceHandlerFactory-Integrated" />
          <remove name="svc-Integrated" />
          <remove name="WebDAV" />
          <add name="svc-Integrated" path="*.svc" verb="*" type="System.ServiceModel.Activation.HttpHandler, System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" preCondition="integratedMode" />
          <add name="OwssvrHandler" scriptProcessor="C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\isapi\owssvr.dll" path="/_vti_bin/owssvr.dll" verb="*" modules="IsapiModule" preCondition="integratedMode" />
          <add name="ScriptHandlerFactory" verb="*" path="*.asmx" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
          <add name="ScriptHandlerFactoryAppServices" verb="*" path="*_AppService.axd" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
          <add name="ScriptResource" preCondition="integratedMode" verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
          <add name="JSONHandlerFactory" path="*.json" verb="*" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" resourceType="Unspecified" preCondition="integratedMode" />
          <add name="ReportViewerWebPart" verb="*" path="Reserved.ReportViewerWebPart.axd" type="Microsoft.ReportingServices.SharePoint.UI.WebParts.WebPartHttpHandler, Microsoft.ReportingServices.SharePoint.UI.WebParts, Version=10.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91" />
          <add name="ReportViewerWebControl" verb="*" path="Reserved.ReportViewerWebControl.axd" type="Microsoft.Reporting.WebForms.HttpHandler, Microsoft.ReportViewer.WebForms, Version=8.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
          <add name="Telerik.Web.UI.WebResource" verb="*" preCondition="integratedMode" path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" />
        </handlers>

    please help me to resolve the issue asap, waiting for ur reponse
    Thanks in advance
  2. PJ
    PJ avatar
    3 posts
    Member since:
    Nov 2009

    Posted 23 Feb 2014 in reply to jai Link to this post

    Hi,
    What was the solution for this issue? I'm having the same problem.

    Thanks,
    -PJ
  3. UI for ASP.NET Ajax is Ready for VS 2017
Back to Top