No properties in design view and Visual Studio crashes

4 posts, 0 answers
  1. Michael
    Michael avatar
    2 posts
    Member since:
    Feb 2013

    Posted 07 Feb 2013 Link to this post

    Hi,

    we are using Version 2012.3.1308.35 of Telerik dll´s and Visual Studio 2010 in a SharePoint 2010 project. All 3 dll´s (Web.UI, Web.Design, Web.UI.Skins) are properly deployed to the GAC. I´ve added the Telerik controls to the toolbox as described.

    When I drop the AsynUpload to a page, Visual Studio displays no properties in the properties window and the SmartTag functions are not displayed. When I selected the AsyncUpload control from the properties window dropdown, Visual Studio crashes every time.

    When I deploy the solution to SharePoint and click on the "Select" button, sometimes Internet Explorer crashes without any message, or I get an cryptic javascript error message.

    All other Telerik controls show up properly in Visual Studio designer and work fine.

    Do you have any clues how to solve this isssue?

    Thank you!
  2. Plamen
    Admin
    Plamen avatar
    2729 posts

    Posted 12 Feb 2013 Link to this post

    Hi Michael,

     
    I have tested the design time with RadAsyncUpload in a sample isolated page but could not observe the same issue. Here is my test project . Please review it and let me know what else should be changed in order to observe the unusual behavior and be more helpful.

    Kind regards,
    Plamen
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Michael
    Michael avatar
    2 posts
    Member since:
    Feb 2013

    Posted 15 Feb 2013 Link to this post

    Hi,

    Thank you for your reply. I got the Async Upload Control working. But I still can´t use the design view or smart tags. So I added the entries in the web.config manually. Maybe my Visual Studio 2010 installation has some problems, I don´t know. We will update to Visual Studio 2012 soon, so maybe then the problem is solved.

    Thanks again.
  5. Plamen
    Admin
    Plamen avatar
    2729 posts

    Posted 19 Feb 2013 Link to this post

    Hello,

     
    It is quite unusual that the design-view or the smart tag does not work since it worked properly at my side in the project that  I sent you. Yet I would like to confirm that event without working design time our controls have all their functionality working properly in Source-View and if you set the mouse cursor on the mark up of the control and press F4 its properly window is shown and ready for easy update.

    Hope this will be helpful. 

    All the best,
    Plamen
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
Back to Top