Nested Grid InPlace edit problem

3 posts, 1 answers
  1. Andy Green
    Andy Green avatar
    120 posts
    Member since:
    Jul 2009

    Posted 03 Aug 2009 Link to this post

    Hi

    I have a nested RadGrid, set up for In place editing.

    The Top level is fine in that when I hit add new I get 1 text box (thats all there is ID & Name) for my value and icons to add or cancel.

    The data is passed back and handled by a proc.

    However, the nested grid behaves differently, there are 2 text boxes one prefixed with a : and the icons have gone and in its place 'insert' & 'cancel'.

    The path to the images is the same, any ideas what is going on.

    Andy
    <telerik:RadGrid   
        ID="rgOrganisation"   
        runat="server"   
        GridLines="None" 
        Width="500px"   
        AutoGenerateColumns="False" 
        Skin="CPSM"   
        EnableEmbeddedSkins="False">  
          
            <MasterTableView DataKeyNames="Organisation_ID" EditMode="InPlace" CommandItemDisplay="None">  
                <Columns> 
                    <telerik:GridBoundColumn DataField="Organisation_ID" DataType="System.Int32" HeaderText="Organisation_ID" ReadOnly="True" SortExpression="Area_ID" UniqueName="Organisation_ID" Visible="False"></telerik:GridBoundColumn> 
                    <telerik:GridBoundColumn DataField="Organisation" HeaderText="Organisation" SortExpression="Organisation" UniqueName="Organisation"></telerik:GridBoundColumn> 
                </Columns> 
     
                <RowIndicatorColumn><HeaderStyle Width="20px" /></RowIndicatorColumn>  
                <ExpandCollapseColumn><HeaderStyle Width="20px" /></ExpandCollapseColumn>  
                  
                <DetailTables> 
                           <telerik:GridTableView runat="server" CommandItemDisplay="Bottom" DataKeyNames="Organisation_ID" Width="100%" > 
                                 
                               <Columns> 
                                   <telerik:GridEditCommandColumn CancelImageUrl="../App_Themes/Default/Grid/Cancel.gif" EditImageUrl="../App_Themes/Default/Grid/Edit.gif" InsertImageUrl="../App_Themes/Default/Grid/Update.gif" UpdateImageUrl="../App_Themes/Default/Grid/Update.gif" ButtonType="ImageButton"><HeaderStyle Width="15px" /><ItemStyle Width="15px" /></telerik:GridEditCommandColumn> 
                                   <telerik:GridBoundColumn DataField="Organisation_ID"  DataType="System.Int32" UniqueName="Organisation_ID" Visible="false"></telerik:GridBoundColumn>        
                                   <telerik:GridBoundColumn DataField="Organisation"  HeaderText="Organisation" ></telerik:GridBoundColumn> 
                                   <telerik:GridButtonColumn ButtonType="ImageButton" CommandName="Delete" Text="Delete" ImageUrl="../App_Themes/Default/Grid/delete.gif" ConfirmDialogType="RadWindow" ConfirmText="Are you sure you want to delete this Location"><HeaderStyle Width="10px" /><ItemStyle Width="10px" /></telerik:GridButtonColumn> 
                               </Columns> 
                                
                               <CommandItemSettings AddNewRecordText="Add new Division" RefreshText=" " /> 
                               <RowIndicatorColumn><HeaderStyle Width="20px" /></RowIndicatorColumn>  
                               <ExpandCollapseColumn><HeaderStyle Width="20px" /></ExpandCollapseColumn>  
                                 
                           </telerik:GridTableView> 
                        </DetailTables> 
              
            </MasterTableView> 
        </telerik:RadGrid> 
  2. Answer
    Princy
    Princy avatar
    17421 posts
    Member since:
    Mar 2007

    Posted 04 Aug 2009 Link to this post

    Hello Andy,

    I suppose you have not set the EditMode to InPlace for your detail table seperately, since i could not find it in your code. Try setting it as shown below and let me know if it helps
    aspx:
    <telerik:RadGrid ID="rgOrganisation" runat="server" GridLines="None" Width="500px" AutoGenerateColumns="False" Skin="CPSM" EnableEmbeddedSkins="False">   
           <MasterTableView DataKeyNames="Organisation_ID" EditMode="InPlace" CommandItemDisplay="None">   
                .....             
              <DetailTables>  
                     <telerik:GridTableView runat="server" CommandItemDisplay="Bottom" EditMode="InPlace" DataKeyNames="Organisation_ID" Width="100%" >  
                      ... 

    Thanks
    Princy.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Andy Green
    Andy Green avatar
    120 posts
    Member since:
    Jul 2009

    Posted 04 Aug 2009 Link to this post

    Thank you  - that fixed it.

    Andy
Back to Top