MultiPage Viewer

3 posts, 0 answers
  1. Kris
    Kris avatar
    9 posts
    Member since:
    Jun 2008

    Posted 19 Jun 2008 Link to this post

    I'm using the RadControls for ASP.NET, specifically the MultiPage control and the tree view.

    I'm trying to load a MultiPage control at runtime with a variable number of pageviews (about 5) with a tree view in each pageview.  Before the code runs the multipage control has one pageview control that is empty.  My code first creats a treeview in memory and adds the treeview to the existing pageviews controls collection.  Then the code runs through a loop to generate a new pageview in memory, generate a tree view in memory, add the tree view to the new pageview contols collection, and finally add the pageview to the multipage controls collection.  In theory this should work.  But in my case it's not.  When the page displays I don't see the control at all.  By looking at the html source I can see that the MultiPage did render along with the original pageview.  There is also a tree view inside the pageview as expected (except I can't see it).  But the strange part is that the other pageviews that were created at runtime are not there.  I'm guessing there is a property I'm missing to show the first pageview that is hidden in the html.  But I can't figure out why the other four pageview controls are not getting added to the collection.

    Please help.
  2. Kris
    Kris avatar
    9 posts
    Member since:
    Jun 2008

    Posted 20 Jun 2008 Link to this post

    I found the issue.

    I wasn't setting the selected index when I loaded the page.  And for the missing tree viewes, I found a missing line in my code (my bad).

    I guess I just needed to sleep on it.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Kellie
    Kellie avatar
    29 posts
    Member since:
    Feb 2009

    Posted 04 Feb 2011 Link to this post

    Hi Kris,

    Just in case I've duplicated your problem, which control did you set the selected index on?

    Thanks,
    Kellie
Back to Top