MossRadEditor : Disabling DocumentManager in LinkManager

2 posts, 0 answers
  1. dmetge
    dmetge avatar
    7 posts
    Member since:
    Jun 2007

    Posted 04 Aug 2010 Link to this post


    we're using MOSSRadEditor in a Sharepoint application. It works fine, but when a user clicks on the "link manager" tool, he can access to a "document manager" icon, which we would like to mask.

    Is there a way to prevent user access to this tool ? Using the configfile.xml, or maybe in the code ?

    Thanks in advance,

  2. Rumen
    Rumen avatar
    12787 posts

    Posted 05 Aug 2010 Link to this post

    Hi Daniel,

    Please, see this live example: Customize Built-in Dialogs. It will show you how to register the external editor's dialogs. After that open the EditorDialogs\LinkManager.ascx file, locate and hide the following element by setting style="display:none;", e.g.

    <td style="display:none;padding-left: 4px;">
        <tools:StandardButton runat="server" id="DocumentManager" Name="DocumentManager">

    Save the file.

    For your MOSS Scenario, you should set the ExternalDialogsPath property in you respective ConfigFile.xml or ListConfigFile.xml, which are located in the /Program Files/Common Files/Microsoft Shared/web server extensions/wpresources/RadEditorSharePoint/5.x.x.0__1f131a624888eeed/Resources/ folder.

    For example add the following code (5.x.x is the version of RadEditor for MOSS. Change the x.x with your version):
    <property name="ExternalDialogsPath">/_wpresources/RadEditorSharePoint/5.x.x.0__1f131a624888eeed/Resources</property>

    Copy the LinkManager.ascx in the mentioned above folder and modify it.

    Kind regards,
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. DevCraft R3 2016 release webinar banner
Back to Top