MOSS RadEditor Image manager custom settings

11 posts, 0 answers
  1. Sohail
    Sohail avatar
    12 posts
    Member since:
    Dec 2008

    Posted 23 Dec 2008 Link to this post

    Hi everyone
                       Is it possible to filter the images list to only approved images? By default the image manager shows all the images in the

    images document library in MOSS 2007. Can we limit this list by using some query for example  " select only the approved items from

    the images list  ". I am using the MossRadEditor in code behind in a web part.

    Regards
    Sohail
  2. Stanimir
    Admin
    Stanimir avatar
    1653 posts

    Posted 29 Dec 2008 Link to this post

    Hi Sohail,

    SharePoint 2007 works with impersonation, so all operations with RadEditor will be performed with the credentials of the currently logged in user. This includes the ImageManager dialogue. If you try to limit the reading rights for the unapproved images, they will not appear in the ImageManager list.


    Sincerely yours,
    Stanimir
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.

  3. Sohail
    Sohail avatar
    12 posts
    Member since:
    Dec 2008

    Posted 29 Dec 2008 Link to this post

    Hi Stanimir
                    Thanks for your reply. This behaviour of MOSS Editor is very cool.  I got a few questions from you.
    1)   Is there any way to customize the Image Manager toolbar. I do not want to display Upload, delete and Image editor buttons.

    2)  Can i show the "ALT image text from a field in the sharepoint list"  to  Image Alt Text textbox? I have stored all the Alt texts in a sharepoint list and i want to display them in the Image Alt textbox (in the Image Manager) if possible?


    Kind regards

    sohail
  4. Sohail
    Sohail avatar
    12 posts
    Member since:
    Dec 2008

    Posted 29 Dec 2008 Link to this post

    Sorry i forgot to post the third question

    3) Is it possible to hide the Alt image text box ?  i need this if we can not get Alt text value from the sharepoint list.

    Thanks

    Sohail
  5. Stanimir
    Admin
    Stanimir avatar
    1653 posts

    Posted 31 Dec 2008 Link to this post

    Hi Sohail,

    Here are a couple of articles that you might find useful on the matter.
    1. In our online help: ExternalDialogsPath property
    2. In our online knowledge base Using the Image and Document managers outside RadEditor

    I hope this helps.


    Best wishes,
    Stanimir
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  6. Sohail
    Sohail avatar
    12 posts
    Member since:
    Dec 2008

    Posted 31 Dec 2008 Link to this post

    Hi Stanimir 
      Thanks for your reply. Yes the articles are helpful but i could not find the location of EditorDialogs folder. I am using the

    MOSSRadEditor in the code behind using RadEditorsharepoint.dll . I have checked the 12 hive sharepoint folder and the

    c:\windows/telerik but no luck.  even i have checked the installation files i could not find it even in there.

    Can you please let me know where it exists?

    Regards
  7. Stanimir
    Admin
    Stanimir avatar
    1653 posts

    Posted 31 Dec 2008 Link to this post

    Hello Sohail,

    Download the Free trial version of RadControls for ASP.NET AJAX http://www.telerik.com/account/free-trials.aspx. You will find EditorDialogs folder in Telerik.Web.UI_2008_3_1125_trial.zip.

    I hope this helps.


    Best wishes,
    Stanimir
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  8. Sohail
    Sohail avatar
    12 posts
    Member since:
    Dec 2008

    Posted 02 Jan 2009 Link to this post

    Thanks Stanimir 
                            This all worked.

    Sohail
  9. Sohail Sarwar
    Sohail Sarwar avatar
    4 posts
    Member since:
    Apr 2010

    Posted 19 Apr 2010 Link to this post

    Hi
     The Tererik Editor removes the <P> tag if there is only one paragraph in the editor. If i remove the content filers by setting <property name="ContentFilters">None</property> this fixes the issue but on the web pages some of the P tags merge. Very strange!. Any help will be appreciated

    Sohail
  10. Stanimir
    Admin
    Stanimir avatar
    1653 posts

    Posted 20 Apr 2010 Link to this post

    Hello Sohail,

    Could you provide us with some sample HTML code and a step by step scenario of how to reproduce the issue?

    Thank you.


    Sincerely yours,
    Stanimir
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  11. Sohail Sarwar
    Sohail Sarwar avatar
    4 posts
    Member since:
    Apr 2010

    Posted 20 Apr 2010 Link to this post

    Sorry Stanmir

                        I have posted this issue in a new forum and you suggested me to to use
    <property name="ContentFilters">RemoveScripts,MakeUrlsAbsolute,FixUlBoldItalic,IECleanAnchors,MozEmStrong,ConvertFontToSpan,ConvertToXhtml,IndentHTMLContent
    </property>

    That has fixed the problem. Infact the <P> tag was disappearing and i disabled the contentfilter " FixEnclosingP ", which fixed this issue.

    Thanks a lot for your help

    Sohail
Back to Top