MOSS Rad Editor - Read only mode

4 posts, 0 answers
  1. Nishim
    Nishim avatar
    17 posts
    Member since:
    Feb 2007

    Posted 25 Feb 2008 Link to this post

    Hi

    I am using full featured MOSS Rad Editor in list items. It is perfect. I want to use MOSS Rad Editor to display the contents on home page.

    I am using MOSS RadEditor in my web part.

    Telerik.SharePoint.

    MOSSRadEditor radEditor;


     protected override void CreateChildControls()

    {

    base.CreateChildControls();

    radEditor =

    new MOSSRadEditor();

    radEditor.ID =

    "contentDisplay";

    radEditor.RadControlsDir =

    "~/_layouts/RadControls";

    this.Controls.Add(radEditor);

    }

    I can see the editor in the web part and contents also but I have two problems:

    1. I want the editor should be view mode only. It should not allow user to modify contents. Right now when I click inside the editor, it turns into edit mode.

    2. The editor does not show Flash files and media files.


    Please look into this and let me know the solution asap.

    Thanks in advance

    Umesh

  2. Lini
    Admin
    Lini avatar
    2144 posts

    Posted 27 Feb 2008 Link to this post

    Hello Nishim,

    You can use the Editable property and set to false. This way users will not be able to edit content:

    radEditor.Enabled = false;

    I am not sure what you mean with the second question. If you want to see the insert flash and media tools in the editor toolbar, then you need to add them in the editor tools file. If the flash and media are already in your content and they were added using the RadEditor WCM publishing field, then you need to use the UnEscapeSpecialTags to decode the flash and media objects:

    radEditor.Content = Telerik.SharePoint.

    EditorTools.UnEscapeSpecialTags(yourHtmlContent);

    Best wishes,
    Lini
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center

  3. Nishim
    Nishim avatar
    17 posts
    Member since:
    Feb 2007

    Posted 27 Feb 2008 Link to this post

    Hi

    Thanks for your reply.

    I set
    radEditor.Enabled =false;
    radEditor.Editable = false;

    but sitll it is showing a pencil at top and when I click, the editor turn on into edit mode. How I can prevent this?

    I also want the vertical scroll bar should appear if contents are more than a page size. How I can get scroll bar in view mode?

    I could not find Telerik.Sharepoint.EditorTools namespace/class. Could you please tell me "EditorTools" class comes under which namespace?

    Thanks & Regards

    Umesh
  4. Lini
    Admin
    Lini avatar
    2144 posts

    Posted 05 Mar 2008 Link to this post

    Hello Nishim,

    If you do not want to see the pencil icon, you need to set the HasPermission property to false:

    RadEditor1.HasPermission = false;

    The EditorTools class is in the Telerik.SharePoint namespace, which is in the RadEditorSharePoint.dll assembly. The assembly is part of the RadEditor for MOSS installation.

    Regards,
    Lini
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
Back to Top