MOSS Link Manager giving JavaScript Error

13 posts, 0 answers
  1. Steve
    Steve avatar
    21 posts
    Member since:
    Oct 2007

    Posted 15 Oct 2007 Link to this post

    When I use the MOSS Link Manager, I get a JavaScript error. I click the button and get:

    Line: 90
    Char: 2
    Error: 'AssetPickerConfig' is undefined
    Code: 0

    Any reason for this?
  2. Steve
    Steve avatar
    21 posts
    Member since:
    Oct 2007

    Posted 17 Oct 2007 Link to this post

    Anyone have an idea on this? Or is there a way I can use the one that comes with the regulat moss? I want my users to be able to browse files on the server (like you can with images)... Does anyone have any idea on this? This is the last thing I have left to do before I launch by Web Content Management System...

    Thanks
    Steve

  3. Georgi Tunev
    Admin
    Georgi Tunev avatar
    7207 posts

    Posted 18 Oct 2007 Link to this post

    Hello Steve,


    We are familiar with this problem and we fixed it in our internal builds. We plan to release a new update of RadEditor for MOSS next week and the problem will be fixed there as well.

    However, just to make sure that your problem will be solved with the new update, can you please open a new support ticket and send us the Html dump of the page where you get this error so we can check it?

    Thank you in advance for your cooperation.




    All the best,
    Georgi Tunev
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  4. Steve
    Steve avatar
    21 posts
    Member since:
    Oct 2007

    Posted 18 Oct 2007 Link to this post

    Hey Georgi... How can I get the HTML dump like you ask for, and where do I open a new support ticket?

    When next week do you expect the update to be out?

    Thanks alot!!

    Steve
  5. Steve
    Steve avatar
    21 posts
    Member since:
    Oct 2007

    Posted 18 Oct 2007 Link to this post

    Georgi, I could not submit a ticket: "We are sorry, but your support package is not active. " ... Anyways, I found out how to do a html dump by reading anotehr article on the forums (http://www.telerik.com/community/forums/thread/b311D-mhhct.aspx). I assume you want the source of my page that this error is on. I can send it to you, if you give me an email to send to.

    I followed what was in that article and the AssetPickers.js file was where it was supose to be... But there was no reference to this .js file in the source code I had. This was on a page with the RadEditor... I did check another page using the regular editor and the .js file was there....

    let me know where to send this to...

    Also, what day do you expect the new version to be released on...
  6. Georgi Tunev
    Admin
    Georgi Tunev avatar
    7207 posts

    Posted 22 Oct 2007 Link to this post

    Hello Steve,

    We've already released an update - v4.4.1 where the problem is fixed. It is available in your Client.net account - can you please update your application and let us know if the problem is solved?



    Regards,
    Georgi Tunev
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  7. Steve
    Steve avatar
    21 posts
    Member since:
    Oct 2007

    Posted 22 Oct 2007 Link to this post

    Hello Georgi,

    Everything seems to be workign fine now, at least from what I have been testing! The Moss Link Manager works like a charm!!

    Thanks for the help and support!

    Keep up the great work on this product...
  8. Steve
    Steve avatar
    21 posts
    Member since:
    Oct 2007

    Posted 22 Oct 2007 Link to this post

    ok, I did find one thing. I should not have posted that so quickly... When using FireFox, and I pull up the MOSS Link Manager, it will open, but when I click on the link I want to add, it will not show up in the "Selected URL" text box... Not a big deal for me, but just thought you should know... This is probably a problem with the actual MOSS Link Manager (since the OTB Text Editor is only good in IE... maybe the same for the Link Manager), and nothing to do with RadEditor
  9. Georgi Tunev
    Admin
    Georgi Tunev avatar
    7207 posts

    Posted 23 Oct 2007 Link to this post

    Hi Steve,

    Indeed, you are right - the problem is with MOSS' Link manager which does not work correctly under Firefox. Unfortunately there isn't much that we can do about this as we cannot control the manager.




    Sincerely yours,
    Georgi Tunev
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  10. Steve
    Steve avatar
    21 posts
    Member since:
    Oct 2007

    Posted 23 Oct 2007 Link to this post

    Georgi,

    I guess a nice addition to the RadEditor in future versions would be to make the RadEditor Link Manager like the MOSS Link Manager, so that the user can select links instead of having to type them in. Exactly like what you have done with the Image Manager. This would be great for people who have users who use various browsers. But I am sure you already have that on your list of things to complete.

    Thanks again,
    Steve
  11. Georgi Tunev
    Admin
    Georgi Tunev avatar
    7207 posts

    Posted 23 Oct 2007 Link to this post

    Hi Steve,

    Yes, it is in our ToDo list, however I cannot tell if we will be able to implement it. The problem here comes from the fact that we don't have access to the MOSS libraries with these hyperlinks.

    For the other dialogs - Image Manager, Document Manager etc, we are browsing files in the MOSS resource galleries to which we have access, however, when it comes to hyperlinks, we are restricted to the MOSS Hyperlink Manager which unfortunately doesn't work under Firefox.

    Of course if in the future the MOSS hyperlink manager is available under Firefox, we will change our own link manager and add hyperlink browsing, but for now we cannot tell when this will happen.




    Greetings,
    Georgi Tunev
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  12. micatcsiro
    micatcsiro avatar
    1 posts
    Member since:
    May 2007

    Posted 07 Jan 2008 Link to this post

    I am using RadEditor Lite v141 with my WSS3 installation and I am having the same problem as Steve - clicking on the MOSS Link Manager when using IE results in the same javascript error he described. I looked for the AssetPickers.js in my web server externsions folder and it doesn't exist.

    Now I presume this is all because I'm using WSS. When I use CTRL-K I get the HyperlinkManager so how do I go about replacing the MOSS Link Manager action with the RadEditor HyperlinkManager?

    Thanks,

    Michael.
  13. Lini
    Admin
    Lini avatar
    2144 posts

    Posted 08 Jan 2008 Link to this post

    Hi Michael,

    You need to edit the editor's tools file and rename the MOSSLinkManager tool to LinkManager. Here is a page with more information about the tools file: http://www.telerik.com/help/radeditormoss/Removing%20tools%20from%20the%20toolbar.html

    Best wishes,
    Lini
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
Back to Top