Mobile Calendar Issues

5 posts, 0 answers
  1. Dan Cornish
    Dan Cornish avatar
    28 posts
    Member since:
    Apr 2010

    Posted 18 Feb 2012 Link to this post

    I'd like to submit a request for a calendar that is fully functional on touch devices.  I'm experiencing at least a couple problems with the Kendo UI Web Calendar control:

    1. On both my iPad2 and my Android HTC EVO, when clicking on days within the calendar a "#" is appended to the URL.  This causes issues when used with a Kendo UI Mobile application.

    2. Clicking on days doesn't fully highlight the selected day.  It leaves the selected day in a hover-like state.  For example, in the Default theme, the selected day is not orange like it is in a desktop browser.

    Are you guys considering a Calendar widget for the formal Kendo UI Mobile release in March?

    Thanks. 
  2. Georgi Krustev
    Admin
    Georgi Krustev avatar
    3707 posts

    Posted 22 Feb 2012 Link to this post

    Hello Dan, 

    Currently our plans do not include such implementation, but I will add it as a feature request in our internal system. If we receive more requests for the same functionality, we will schedule it for investigation.

    As to the other questions:
    #1:
    I could not replicate the issue locally. Could you please share the current implementation with us? Thus I will be able to review it and advice your further.

    #2:
    This is a known issue and will be fixed for the next official release of Kendo UI.

    Regards,
    Georgi Krustev
    the Telerik team
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
  3. Kendo UI is VS 2017 Ready
  4. Dan Cornish
    Dan Cornish avatar
    28 posts
    Member since:
    Apr 2010

    Posted 22 Feb 2012 Link to this post

    The attached image is a screenshot taken from my iPad2 on your demo site.  Notice the "#" on the end of the URL.  Also, notice the selected date is gray.

    I've also attached my implementation using the Calendar within a Kendo UI Mobile app.  In addition to the "#" being appended to the URL, sometimes on my Android HTC EVO a "#/" is appended to the URL.  This causes the app to go to a black screen.  The black screen is most likely due to the fact that the app is trying to go to a tab which it cannot find.

    Please let me know if there is a way to correct this issue.  Thanks.
  5. Dan Cornish
    Dan Cornish avatar
    28 posts
    Member since:
    Apr 2010

    Posted 22 Feb 2012 Link to this post

    I'm able to reproduce the "#/" problem on my iPad2 as well.  

    For simplicity, I've stripped down the project to just a Calendar control and a tab strip (see attached).  I've taken screenshot of what the app looks like before and after the problem occurs.  Notice the "#/" on the end of the URL in AFTER.png.  Also, notice the app goes to a blank screen.

    The problem doesn't typically happen immediately.  Rather it sometimes seems to occur when two days in the calendar are inadvertently clicked simultaneously, but I can't say that's the cause with any certainty.

    Please let me know if there is a way around this issue.
  6. Georgi Krustev
    Admin
    Georgi Krustev avatar
    3707 posts

    Posted 23 Feb 2012 Link to this post

    Hello Dan,

     
    Thank you for the test page and for clearing the things up. This is a known issue and we are working on it. Our goal is to fix it for the next official release of Kendo UI.

    Regards,
    Georgi Krustev
    the Telerik team
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
Back to Top
Kendo UI is VS 2017 Ready