MediaPlayer Issue on the latest version

14 posts, 2 answers
  1. Marc Roussel
    Marc Roussel avatar
    429 posts
    Member since:
    Dec 2009

    Posted 24 Jun 2010 Link to this post

    How do you remove this big play button in the center that doesn't work anyway ? It is confusing people !
    Or at least make it works.  Any workaround to remove it ?
  2. DevCraft banner
  3. Dimitrina
    Admin
    Dimitrina avatar
    442 posts

    Posted 25 Jun 2010 Link to this post

    Hello Marc,

    We are really sorry for the inconvenience caused. This issue is already fixed and the change will be reflected in the upcoming internal build.
    However, if you still want to remove the big play button you have to edit the control template of the RadMediaPlayer in Blend. For more information you can follow the link below:
    http://www.telerik.com/help/silverlight/radcontrols-for-silverlight-expression-blend-support.html

    Please find attached an example, illustrating how to create a custom style to remove the big PlayButton from the control .

    If you have further questions please do not hesitate to ask us.
    I hope this will help you.


    All the best,
    Dimitrina
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  4. Marc Roussel
    Marc Roussel avatar
    429 posts
    Member since:
    Dec 2009

    Posted 25 Jun 2010 Link to this post

    Hi,

    Thank you for the fix.
    For the workaround, I can't go in Blend as the MediaPlayer is added at runtime in C# code.
    Is there a way by C# code to remove the BIG play button ?
  5. Answer
    Dimitrina
    Admin
    Dimitrina avatar
    442 posts

    Posted 28 Jun 2010 Link to this post

    Hi Marc,

    The issue with the Big Play button is already fixed with the new version (2010_1_0625) of our assembles. Please find attached a project.

    If you have further questions please do not hesitate to ask us.
    I hope this will help you.

    Sincerely yours,
    Dimitrina
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  6. Marc Roussel
    Marc Roussel avatar
    429 posts
    Member since:
    Dec 2009

    Posted 28 Jun 2010 Link to this post

    Indeed. It works fine.  Thank you
  7. Marc Roussel
    Marc Roussel avatar
    429 posts
    Member since:
    Dec 2009

    Posted 04 Oct 2010 Link to this post

    Hi,  I just installed version 924 and I have the big play button stay in the middle even if I press it.
    Well, there's a certain circumstence in which it does not work.

    Let say you start the video then you close it with the X and we restart it, and what I see is that the video is position where it was before closing without the big play button in the middle then I go to the playlist and select the video and then the button appear so I click play and it stays there.

    You should be able to see a video on my site : http://gearworled.dyndns.org:8082/?VIDEO=1&PL=1
    or you could try it yourself by going at http://gearworled.dyndns.org:8082 and using the Public video link on the left menu
    Press the Menu button to bring the menu first.

    So here are the steps to reproduce it

    1) Click the Menu button on the upper left corner of the screen
    2) Click on the Video publiques link
    3) Start the video by clicking the big play button and then let play it for a few seconds and then click the X button of the window
    4) Click on the Video publiques again and then try to play the video by going on the play list.

    Regardless of me having to do something, this button should not stay there after pressing it for any reason...
  8. Marc Roussel
    Marc Roussel avatar
    429 posts
    Member since:
    Dec 2009

    Posted 04 Oct 2010 Link to this post

    I need like a way to reset the whole RadMediaPlayer so it is like it never played any video yet, because when I quit a RadWindow that containts the RadMediaPlayer, since my Window still exist and for performance reason I keep it, when I reopen the window, the states of the RadMediaPlayer is exactly the same as when I left it except the BIG button is there and even thought I click it to let say continue the video,  the button remains there while the video is playing.
  9. Hristo
    Admin
    Hristo avatar
    352 posts

    Posted 07 Oct 2010 Link to this post

    Hi Marc Roussel,

    Unfortunately we were not able to simulate the issue you are experiencing. Also the links you provided are not accessible, can you please revise them.

    I created a test project but apparently I'm missing something from your scenario. Can you provide us a simple repro project that demonstrates the issue. I think the difference is in the way you are closing the window or stopping the movie. Also you may modify the attached project fragment to replicate the issue (the whole project is quite big that is why I'm sending only these 4 files).

    We are currently revising our media player in order to improve it. So, I'm eagerly looking forward to repro and fix this issue too.

    Kind regards,
    Hristo Milyakov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  10. Marc Roussel
    Marc Roussel avatar
    429 posts
    Member since:
    Dec 2009

    Posted 14 Oct 2010 Link to this post

    I did place a ticket with a repro...

    By the way, this has been a long time asking you why you can't access a simple Silverlight website as I just tested with 25 peoples and it's very accessible.  Is it a security reason on your side ?  I would have liked to understand why you Telerik guys aren't able to connect.

    http://gearworld.dyndns.org:8082 is a valid and opened web site between 6:00am and 7:00pm Eastern Time (US & CANADA)
  11. Answer
    Hristo
    Admin
    Hristo avatar
    352 posts

    Posted 15 Oct 2010 Link to this post

    Hi Marc Roussel,

    We handled the ticket with repro project :)

    I'm also confused about the reasons we can not access the link. I asked several colleagues, some of them not working for Telerik, but they all failed to open it. All requests were made from Bulgaria, so it could be something related to this fact.

    See following link for prove: http://screencast.com/t/goXgFpvQ . 5 o'clock PM Bulgaria time is 10 o'clock AM Eastern Time (US & CANADA), am I right? I can see that my previous try has been around 2 PM (Sofia) which is around 7 AM your time. It should be working as you said but apparently there is some issue.

    Please let us know if you need more help.

    Greetings,
    Hristo Milyakov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  12. Marc Roussel
    Marc Roussel avatar
    429 posts
    Member since:
    Dec 2009

    Posted 15 Oct 2010 Link to this post

    Ok thank you for the information.
  13. ying
    ying avatar
    27 posts
    Member since:
    May 2011

    Posted 23 May 2011 Link to this post

    can you tell me which sentence is used to remove the big play button???
  14. Kiril Stanoev
    Admin
    Kiril Stanoev avatar
    1512 posts

    Posted 26 May 2011 Link to this post

    Hello Ying,

    I've posted an answer to your other forum thread. Please have a look at it and let me know if it help.s

     

    Regards,
    Kiril Stanoev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Back to Top
DevCraft banner