IsEnabled=False does not grey out control

12 posts, 0 answers
  1. Jorn
    Jorn avatar
    222 posts
    Member since:
    Jun 2009

    Posted 04 Oct 2010 Link to this post

    Title says it all; when I disable the datepicker it visually appears as if still enabled
    Pretty minor, but it stands out when all other controls are disabled.
  2. Boyan
    Admin
    Boyan avatar
    758 posts

    Posted 07 Oct 2010 Link to this post

    Hello Jorn,

    Could you please specify which version of our controls you are using as in the latest version RadDatePicker has a disabled state. I have attached how the disabled and enabled state look with our latest release 2010.2.924. Also you can specify if you are using something else than just set IsEnabled property to false.

    All the best,
    Boyan
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. DevCraft banner
  4. Jorn
    Jorn avatar
    222 posts
    Member since:
    Jun 2009

    Posted 07 Oct 2010 Link to this post

    I use the latest release and I user the Windows 7 Theme in my application

    Attached is a screenshot. As you can see the datepicker is almost identical when disabled (to the left).
    There's a disabled textbox above that exhibits the correct visual look (grey text).
  5. Pana
    Admin
    Pana avatar
    748 posts

    Posted 13 Oct 2010 Link to this post

    Hello Jorn,

    The Windows7 does have that glitch. We will try to fix the issue for one of the upcoming releases.

    Sincerely yours,
    Panayot
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  6. Jorn
    Jorn avatar
    222 posts
    Member since:
    Jun 2009

    Posted 13 Oct 2010 Link to this post

    Should I create a ticket or have you created one internally?
  7. Pana
    Admin
    Pana avatar
    748 posts

    Posted 14 Oct 2010 Link to this post

    Hello Jorn,

    The next Q release will be in about half a month but if it is urgent for you I can send you the Windows7 earlier if it is urgent for your application.

    All the best,
    Panayot
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  8. Jorn
    Jorn avatar
    222 posts
    Member since:
    Jun 2009

    Posted 14 Oct 2010 Link to this post

    If it is near the end of this month I can wait, thank you! (I just wanted to make sure this issue have your attention)
  9. Pana
    Admin
    Pana avatar
    748 posts

    Posted 15 Oct 2010 Link to this post

    Hello Jorn,

    It is scheduled for the second week of November.

    All the best,
    Panayot
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  10. Jorn
    Jorn avatar
    222 posts
    Member since:
    Jun 2009

    Posted 15 Oct 2010 Link to this post

    Ok, thanks - I'll keep an eye on it
  11. Rakesh
    Rakesh avatar
    4 posts
    Member since:
    Sep 2011

    Posted 01 Sep 2011 Link to this post

    Hello, we are using latest controls "2010.2.924.1040" and still date part does not grey out upon enable set to False. Can you please let me know if this fix was done.

    Rakesh


  12. Pana
    Admin
    Pana avatar
    748 posts

    Posted 03 Sep 2011 Link to this post

    Hi,

    The RadDatePicker, RadTimePicker and RadDateTimePicker are fixed. See the attached screenshot.

    I am not sure but the image you provide seems to be from other control such as RadScheduler or parts of it. If it is so please upgrade to the RadDatePicker.

    All the best,
    Pana
    the Telerik team

    Thank you for being the most amazing .NET community! Your unfailing support is what helps us charge forward! We'd appreciate your vote for Telerik in this year's DevProConnections Awards. We are competing in mind-blowing 20 categories and every vote counts! VOTE for Telerik NOW >>

  13. Rakesh
    Rakesh avatar
    4 posts
    Member since:
    Sep 2011

    Posted 16 Sep 2011 Link to this post

    Thanks changed it to use raddatetimepicker and everything works. 
Back to Top
DevCraft banner