Increasing linespace after each detailitem

8 posts, 1 answers
  1. Geejay
    Geejay avatar
    45 posts
    Member since:
    Feb 2007

    Posted 02 Dec 2008 Link to this post

    Hello Telerik,

    I just upgraded to Telerik Reporting Q3 and I get messages from users that there's something wrong with the layout. Indeed there's someting different and that is that printed items are moving away from each other. For an example of what I mean: http://80.69.83.12:81/downloads/downloads/IncreasingLineSpace.png At the top everything is normal but the next items show increasing white spaces between items. I tried several things already, also colored some items to figure out what the problem can be. Can you give me an solution for this behaviour?

    Thanks!

    Geert
  2. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 02 Dec 2008 Link to this post

    Hi Geejay,

    We were not able to open the url for some reason, but we have encountered and fixed similar bug, that manifested itself only when having subreports items that do not fit on a single page. Can you confirm that this is the case? If so the good news is that it has been addressed and would be part of the SP1 scheduled for the end of the week.
    If you think this is a different issue, please open a support ticket and provide us with a sample report showing the problem.

    Best wishes,
    Steve
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  3. DevCraft banner
  4. Geejay
    Geejay avatar
    45 posts
    Member since:
    Feb 2007

    Posted 02 Dec 2008 Link to this post

    Hi Steve,

    thanks for the quick reply. Indeed, the subreport does not fit on a single page. However, there's another subreport preceding the multipage subreport which always has 4 items and also shows this behaviour. I'll give you an URL that hopefully works: http://80.69.83.12/downloads/IncreasingLineSpace.png and http://80.69.83.12/downloads/IncreasingLineSpace2.png The first one spreads out over multiple pages.

    Thanks.

    Geert
  5. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 03 Dec 2008 Link to this post

    Hello Geejay,

    This seems like the same issue and it would be addressed for the SP1. It is enough to have a single subreport that stretches to several pages and the whole rendering of the main report is getting messed up because of it.

    Best wishes,
    Steve
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  6. Geejay
    Geejay avatar
    45 posts
    Member since:
    Feb 2007

    Posted 03 Dec 2008 Link to this post

    Hi Steve,

    thanks for the quick response, I'm looking forward to SP1

    Best wishes,

     

    Geert

  7. Geejay
    Geejay avatar
    45 posts
    Member since:
    Feb 2007

    Posted 08 Dec 2008 Link to this post

    Hi Steve,

    last week you wrote that at the end of the week SP1 was scheduled for release.
    Can you give me an update when this is going to happen?

    Best wishes

    Geert
  8. Answer
    Steve
    Admin
    Steve avatar
    10941 posts

    Posted 08 Dec 2008 Link to this post

    Hello Geejay,

    We needed more time for polishing and testing the release and that is why we have rescheduled it for tomorrow.

    Best wishes,
    Steve
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  9. Geejay
    Geejay avatar
    45 posts
    Member since:
    Feb 2007

    Posted 10 Dec 2008 Link to this post

    Hi Steve,

    Just to let you know: the service pack solved the problem!
    Thanks.

    Best wishes

    Geert
Back to Top
DevCraft banner