IME popup appears behind ComboBox's popup

4 posts, 0 answers
  1. Zhang
    Zhang avatar
    13 posts
    Member since:
    Oct 2013

    Posted 11 Mar 2014 Link to this post

    My ComboBox is editable for filtering, i need to type Chinese characters and i found some popular Chinese IME's pop-up windows apprear behind RadComboBox's.
    It makes me cannot see matched Chinese character options. So is there any IME functionality with Telerik controls.
  2. Rosen Vladimirov
    Rosen Vladimirov avatar
    640 posts

    Posted 14 Mar 2014 Link to this post

    Hello Zhang,

    RadControls and WPF itself, do not provide handling of IME, you have to set it explicitly and several issues may occur. Could you provide more details or sample project, reproducing the unexpected behavior, so we can test it on our side?

    I'm looking forward to hearing from you.

    Rosen Vladimirov

    DevCraft Q1'14 is here! Watch the online conference to see how this release solves your top-5 .NET challenges. Watch on demand now.

  3. DevCraft R3 2016 release webinar banner
  4. John
    John avatar
    18 posts
    Member since:
    Mar 2013

    Posted 15 Apr 2015 in reply to Rosen Vladimirov Link to this post

    Hi Rosen,

     What do you mean, "you have to set it explicitly and several issues may occur"?

    I have a situation when inputting into an editable ComboBox and desiring Autocomplete functionality via Chinese IME input--only the first character will result in the text field leading Autocomplete simply to the first instance of a word starting with that character.  Thus afterward the user must scroll to the exact word they seek.  This would be akin to typing in "Telerik" and only the "T" appearing and autocomplete going to the first instance of names starting with "T," thus having to scroll past all the T names until coming to "Telerik."

    The user workaround is to type several keystrokes for the first character, hit "Enter;" type several more keystrokes for the second character, hit "Enter;" type several more keystrokes for the third character, hit "Enter"...  This akin to typing T-enter; e-enter, l-enter, e-enter, r-enter, i-enter, k-enter to type Telerik.  This isn't normal Chinese behavior and bad user experience.

    Is this already a known issue?  Is there a solution or technical workaround?  Any suggestions?

  5. Nasko
    Nasko avatar
    555 posts

    Posted 16 Apr 2015 Link to this post

    Hi John,

    We noticed that you posted another post with the exact same question in this forum thread and we responded you in it- please, check my answer. Could we continue the discussion there?


    See What's Next in App Development. Register for TelerikNEXT.

Back to Top