Image vectors in pdf don't display

9 posts, 0 answers
  1. George
    George avatar
    3 posts
    Member since:
    Sep 2010

    Posted 12 Dec 2011 Link to this post

    Hello,

    I have some pdf files with logo of the company.
    The pdf viewer is not able to display it.
     In case I put away the logo, and there is only text in document, then the pdf is displayed fine.
    Is there an issue with vector images in pdfs?
    Do I need to use special format to make it work?
    If there is allowed, I can send a pdf file for you to analize.

    Thank you!
  2. Kammen
    Admin
    Kammen avatar
    312 posts

    Posted 12 Dec 2011 Link to this post

    Hi George,

    Currently, there are known issues with some images in PDF. We are making our best to fix them for the official version of RadPdfViewer in 2012 Q1. It will be great if you could send us the PDF files you have problem with so that we can analyze them. If you are a licensed developer for RadControls for Silverlight, you can open a support ticket and attach the files there.

    All the best,
    Kammen
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

  3. DevCraft banner
  4. Murray
    Murray avatar
    5 posts
    Member since:
    Nov 2012

    Posted 27 Nov 2012 Link to this post

    Is there any update on this?
  5. Kammen
    Admin
    Kammen avatar
    312 posts

    Posted 28 Nov 2012 Link to this post

    Hello Murray,

    This should be fixed long ago. If there is still a problem, we will appreciate it if you can send us a sample document that can be used to reproduce the issue.

    Regards,
    Kammen
    the Telerik team

    Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

  6. Murray
    Murray avatar
    5 posts
    Member since:
    Nov 2012

    Posted 28 Nov 2012 Link to this post

    Hi,

    I am not sure if I am allowed to send you the PDF in question as it contains restricted information.  However it does contain a /Filter /CCITTFaxDecode.  Also it is a PDF/A file (http://www.epa.gov/records/faqs/pdfa.htm).  So that may have something to do with it.  If this doesn't help I will ask for a Test PDF that does not contain confidential information for you to test with.
  7. Murray
    Murray avatar
    5 posts
    Member since:
    Nov 2012

    Posted 28 Nov 2012 Link to this post

    Just checked and we are using the 2012 Q2 Dlls.  Is this issue fixed in those?  Or do we need Q3 dlls?
  8. Murray
    Murray avatar
    5 posts
    Member since:
    Nov 2012

    Posted 28 Nov 2012 Link to this post

    FYI, tested with Q3 dlls, and it still didn't work.
  9. Kammen
    Admin
    Kammen avatar
    312 posts

    Posted 29 Nov 2012 Link to this post

    Hi Murray,

    Sometimes RadPdfViewer has problems with files that are encoded with the CCITTFaxDecode. It can handle the common cases, but using some decode parameters may cause the images not to show. Often, this happens with scanned documents. We will really appreciate if you can send us a sample document in order to be more specific about this particular problem.

    Looking forward to your answer.


    Regards,
    Kammen
    the Telerik team

    Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

  10. Murray
    Murray avatar
    5 posts
    Member since:
    Nov 2012

    Posted 29 Nov 2012 Link to this post

    We have a support license with you guys, so I submitted a ticket.  Turns out the issue is with the RunLengthDecode part of the PDF.  I was given feedback on how to fix this.  If it works I will update this ticket.
Back to Top
DevCraft banner