Image Manager formatting

6 posts, 0 answers
  1. Angie
    Angie avatar
    101 posts
    Member since:
    Jan 2008

    Posted 10 Jan 2011 Link to this post

    I am transitioning from an older editor to the Telerik editor.  I saw that you can modify the FileExplorer dialog by editing the usercontrol itself, but my purpose for switching editors was to be able to control how the Editor looked without having to edit multiple files and having all the properties in one place.  It would be nice if there were properties to hide the delete button, new folder button, the left side file explorer, etc.

    Can this be done?

    Thank you.
  2. Rumen
    Admin
    Rumen avatar
    12851 posts

    Posted 12 Jan 2011 Link to this post

    Hello Angie,

    If we add additional properties for every dialog setting this will make the RadEditor configuration extremely hard. That is why we provided external dialog files so that the developers could customize the built-in dialogs.
    Actually you can hide the Delete button by simple not setting the DeletePaths property of the inner ImageManager tag, e.g.

     <telerik:RadEditor ID="RadEditor1" runat="server">
    <ImageManager ViewPaths="~/Images" UploadPaths="~/Images" />
    </telerik:RadEditor>

    To remove the New Folder button and Treeview from the File Browser dialogs, register the external dialogs, open the FileBrowser.ascx file, find the RadFileExplorer declaration and set EnableCreateNewFolder="false" as well as list the desired controls  VisibleControls="AddressBox,ContextMenus,Grid,Toolbar". Save the file and test the dialog.



    Best wishes,
    Rumen
    the Telerik team
    Browse the vast support resources we have to jump start your development with RadControls for ASP.NET AJAX. See how to integrate our AJAX controls seamlessly in SharePoint 2007/2010 visiting our common SharePoint portal.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Angie
    Angie avatar
    101 posts
    Member since:
    Jan 2008

    Posted 12 Jan 2011 Link to this post

    Hi Rumen.  Thank you for your response.  I've tried accessing the external dialogs, I seem to be having the same problem as with the regular dialog boxes, where the "~" is not accurately defining the path.  When I try to define the entire url, it throws an error.  As I mentioned in a different question, my page is running as a subapplication in a larger website.  The editor works fine in the main site, but I cannot get the dialogs to work in the subapplication. 

    The web config has the handlers registered properly, but it cannot seem to find the controls.    Is there a way to define the entire path or a different way to refer to the dialogs so that it will work?

    Update:  The regular dialog boxes work ok in the main site, but I cannot successfully get it to reference the ExternalDialogs, with the path in the editor code and the dialog folder copied to my website.  Thanks.

    Thanks.

    Web Config
    <add path="Telerik.Web.UI.DialogHandler.axd" type="Telerik.Web.UI.DialogHandler" verb="*" validate="false"/>
       <add path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler" verb="*" validate="false"/>

    <handlers>
     <add name="Telerik_Web_UI_DialogHandler_aspx" verb="*" preCondition="integratedMode" path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler" />


    <telerik:radeditor runat="server" ID="RadEditor1" AutoResizeHeight=true Width="680px" Height="500px"  DialogHandlerUrl="~/Telerik.Web.UI.DialogHandler.axd" />

    alternatively:
    <telerik:radeditor runat="server" ID="radEditor" AllowScripts="false" OnClientCommandExecuting="OnClientCommandExecuting"  OnClientLoad="OnClientLoad" AutoResizeHeight=false  EnableResize="false" Skin="Vista"  ExternalDialogsPath="~/EditorDialogs/"   >

    Thank you.
  5. Rumen
    Admin
    Rumen avatar
    12851 posts

    Posted 17 Jan 2011 Link to this post

    Hi Angie,

    I talked with our lead RadEditor developer and he told me the following two suggestions:

    1) set the path without ~/ , e.g.

    DialogHandlerUrl="Telerik.Web.UI.DialogHandler.axd"

    2) Open the web.config of the subapplication with RadEditor in it, and firstly remove the Telerik.Web.UI.DialogHandler.axd handler and after that add it again:

    <remove name="Telerik_Web_UI_DialogHandler_axd" />
    <add name="Telerik_Web_UI_DialogHandler_axd" verb="*" preCondition="integratedMode" path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler" />

    ...

    <remove name="Telerik.Web.UI.DialogHandler.axd" />
    <add path="Telerik.Web.UI.DialogHandler.axd" type="Telerik.Web.UI.DialogHandler" verb="*" validate="false" />

    Best regards,
    Rumen
    the Telerik team
    Browse the vast support resources we have to jump start your development with RadControls for ASP.NET AJAX. See how to integrate our AJAX controls seamlessly in SharePoint 2007/2010 visiting our common SharePoint portal.
  6. Abhinav
    Abhinav avatar
    5 posts
    Member since:
    Feb 2014

    Posted 15 Jun 2015 Link to this post

    Hello,

    To remove the New Folder button from the Image Manager, i have added this ExternalDialogsPath="~/EditorDialogs/" property on the radeditor. Also, added the "EditorDialogs" folder with files on the root of the application. Also, updated the FileBrowser.ascx by setting the EnableCreateNewFolder="false" property.

    In local i have successfully removed the New folder icon from the Image Manager but when the publish the code on the DEVELOPMENT server the this code not worked and show the "New folder" icon.

    Web.config settings are below:

       <httpHandlers>
          <add path="Telerik.RadUploadProgressHandler.ashx" verb="*" type="Telerik.Web.UI.Upload.RadUploadProgressHandler, Telerik.Web.UI"/>
          <add path="Telerik.Web.UI.DialogHandler.aspx" verb="*" type="Telerik.Web.UI.DialogHandler, Telerik.Web.UI, Culture=neutral, PublicKeyToken=121fae78165ba3d4"/>
          <add path="Telerik.Web.UI.SpellCheckHandler.axd" verb="*" type="Telerik.Web.UI.SpellCheckHandler, Telerik.Web.UI, Culture=neutral,

    PublicKeyToken=121fae78165ba3d4"/>
          <add path="ChartImage.axd" verb="*" type="Telerik.Web.UI.ChartHttpHandler, Telerik.Web.UI, Culture=neutral, PublicKeyToken=121fae78165ba3d4" validate="false"/>
          <add path="Telerik.Web.UI.WebResource.axd" verb="*" type="Telerik.Web.UI.WebResource, Telerik.Web.UI" validate="false"/>
          <add type="Telerik.ReportViewer.WebForms.HttpHandler, Telerik.ReportViewer.WebForms, Version=7.2.13.1016, Culture=neutral, PublicKeyToken=a9d7983dfcc261be"

    path="Telerik.ReportViewer.axd" verb="*" validate="true" />
        </httpHandlers>

     

     

    <system.webServer>
        <modules>
          <add name="RadUploadModule" type="Telerik.Web.UI.RadUploadHttpModule, Telerik.Web.UI" preCondition="managedHandler"/>
          <add name="RadCompression" type="Telerik.Web.UI.RadCompression"/>
        </modules>
        <handlers>
          
          <add name="ChartImage.axd_*" path="ChartImage.axd" verb="*" type="Telerik.Web.UI.ChartHttpHandler, Telerik.Web.UI, Culture=neutral,

    PublicKeyToken=121fae78165ba3d4" preCondition="integratedMode,runtimeVersionv2.0"/>
          <add name="Telerik.Web.UI.SpellCheckHandler.axd_*" path="Telerik.Web.UI.SpellCheckHandler.axd" verb="*" type="Telerik.Web.UI.SpellCheckHandler, Telerik.Web.UI,

    Culture=neutral, PublicKeyToken=121fae78165ba3d4" preCondition="integratedMode,runtimeVersionv2.0"/>
          <add name="Telerik.Web.UI.DialogHandler.aspx_*" path="Telerik.Web.UI.DialogHandler.aspx" verb="*" type="Telerik.Web.UI.DialogHandler, Telerik.Web.UI,

    Culture=neutral, PublicKeyToken=121fae78165ba3d4" preCondition="integratedMode,runtimeVersionv2.0"/>
          <add name="Telerik.RadUploadProgressHandler.ashx_*" path="Telerik.RadUploadProgressHandler.ashx" verb="*" type="Telerik.Web.UI.Upload.RadUploadProgressHandler,

    Telerik.Web.UI" preCondition="integratedMode,runtimeVersionv2.0"/>
          <add name="Telerik.Web.UI.WebResource.axd_*" path="Telerik.Web.UI.WebResource.axd" verb="*" type="Telerik.Web.UI.WebResource, Telerik.Web.UI"

    preCondition="integratedMode,runtimeVersionv2.0"/>
          <add name="ScriptResource.axd_GET,HEAD" path="ScriptResource.axd" verb="GET,HEAD" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions,

    Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" preCondition="integratedMode,runtimeVersionv2.0"/>
          <add name="*_AppService.axd_*" path="*_AppService.axd" verb="*" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions,

    Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" preCondition="integratedMode,runtimeVersionv2.0"/>
          <add name="*.asmx_*" path="*.asmx" verb="*" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,

    PublicKeyToken=31bf3856ad364e35" preCondition="integratedMode,runtimeVersionv2.0"/>
          <add name="Telerik.ReportViewer.axd_*" type="Telerik.ReportViewer.WebForms.HttpHandler, Telerik.ReportViewer.WebForms, Version=7.1.13.612, Culture=neutral,

    PublicKeyToken=a9d7983dfcc261be" path="Telerik.ReportViewer.axd" verb="*" preCondition="integratedMode" />
        </handlers>
        <validation validateIntegratedModeConfiguration="false"/>
      </system.webServer>

     

    Please suggest.

     

     

  7. Ianko
    Admin
    Ianko avatar
    1535 posts

    Posted 17 Jun 2015 Link to this post

    Hello Abhinav,

    Make sure that:

    • the EditorDialogs folder exists on the server;
    • the path to the folder is correctly evaluated;

    Try to resolve by removing the tilde (~) character.

    You can also try debugging the deployed project, or at least verify that the evaluated path is properly configured.

    Regards,

    Ianko
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017