Hyperlink title problem in IE

2 posts, 0 answers
  1. Daniel
    Daniel avatar
    1 posts
    Member since:
    Apr 2008

    Posted 28 Apr 2008 Link to this post

    Adding a hyperlink with a title that can be identified as a url (i.e. starts with for example "www." or "http://") causes the title to be replaced with the href attribute when switching between source view and design view or when checking in the page.
    Do anyone know why this is happening and is there some way to turn off this behavior? This only seems to apply to IE browsers.
    I know that this usually isn’t a problem because if the title is a url then it should point to the same thing as the href but we have some redirection logic that in this case is bypassed.

    Let me pull an example just to make things really clear:
    1. Switch to source view and add a new hyperlink:
    <a href="http://XX.XX.XX.XX/">www.yyyyy.com</a>
    2. Switch back to design view.
    3. You will see the hyperlink with the title www.yyyyy.com 
    which is ok. But if you now switch back to source mode you will see that the title has been replaced with the href attribute and looks like this: 
    <a href="http://XX.XX.XX.XX/">http://XX.XX.XX.XX/</a>
  2. Lini
    Admin
    Lini avatar
    2144 posts

    Posted 29 Apr 2008 Link to this post

    Hello,

    We are aware of this problem and it has already been fixed. The fix will be available in the next RadEditor for MOSS release.

    As a temporary workaround, you can try setting the StripAbsoluteAnchorPaths property in the editor's configuration file to True:

    <property name="StripAbsoluteAnchorPaths">True</property>

    http://www.telerik.com/help/radeditormoss/SetPropertiesViaConfigFile.html

    Sincerely yours,
    Lini
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center

Back to Top