HTML button doesn't disappear

5 posts, 0 answers
  1. Jeroen
    Jeroen avatar
    19 posts
    Member since:
    Feb 2009

    Posted 23 Mar 2009 Link to this post

    Hi,

    I'm using the Rad editor for MOSS and i have the following configfile.xml:
    <?xml version="1.0" encoding="utf-8" ?>
    <configuration>
      <property name="ShowHtmlMode">false</property>
      <property name="EnableDocking">False</property>
      <property name="ToolbarMode">PageTop</property>
      <property name="Skin">Gray</property>
      <property name="ImagesPaths">
     <item>/PublishingImages</item>
      </property>
    </configuration>

    But the HTML mode button still appears in the editor. When i change other properties the are applied, but not they ShowHtmlMode.
  2. Stanimir
    Admin
    Stanimir avatar
    1653 posts

    Posted 24 Mar 2009 Link to this post

    Hi Jeroen,

    Could you please verify that your are using RadEditor for MOSS 4.5.4? I tested the issue with the provided configuration, but I noticed that you are using Gray skin, which is not included in the set for 4.5.4 version.
    So I tested the issue with the following config file.
    <configuration> 
      <property name="ShowHtmlMode">False</property> 
      <property name="EnableDocking">False</property> 
      <property name="ToolbarMode">PageTop</property> 
      <property name="Skin">Default2006</property> 
      <property name="ImagesPaths"
        <item>/PublishingImages</item> 
      </property> 
    </configuration> 

    Everything worked as expected. I could not see the Html mode of the RadEditor.


    Kind regards,
    Stanimir
    the Telerik team

    Check out Telerik Trainer , the state of the art learning tool for Telerik products.

  3. Jeroen
    Jeroen avatar
    19 posts
    Member since:
    Feb 2009

    Posted 24 Mar 2009 Link to this post

    I'm using 5.3.2 the latest version.
  4. Stanimir
    Admin
    Stanimir avatar
    1653 posts

    Posted 24 Mar 2009 Link to this post

    Hello Jeroen,

    In 5.3.2 version of RadEditor for MOSS the property that controls the Modes of the control is EditModes. In order to disable the Html view, you need to have the following code in your respective ConfigFile.xml file.
    <property name="EditModes">Design,Preview</property> 

    If you want to disable both Preview and Html modes, add the following code.
    <property name="EditModes">Design</property> 

    I hope this helps.

    Sincerely yours,
    Stanimir
    the Telerik team

    Check out Telerik Trainer , the state of the art learning tool for Telerik products.
  5. Sjeng Koch
    Sjeng Koch avatar
    1 posts
    Member since:
    Dec 2008

    Posted 24 Mar 2009 Link to this post

    That works for me too, thanx.
Back to Top