How do I apply Grid css to a static html table without the vertical scroll?

3 posts, 0 answers
  1. Ryan Lege
    Ryan Lege avatar
    42 posts
    Member since:
    Sep 2008

    Posted 10 Aug 2012 Link to this post

    This is just a static table I'd like to apply the overall Kendo css theme of my site to. Unfortunately, I cannot get rid of the vertical scroll to the right of the table. I've tried everything. Any ideas?  


    <div class="k-widget k-grid" id="Grid">
          <div class="k-grid-header">
            <div class="k-grid-header-wrap">
              <table cellspacing="0">
                <tr>
                  <th>Type</th>
                  <th>Estimate</th>
                  <th>Actual</th>
                  <th>Description</th>
                </tr>
              </table>
            </div>
          </div>
          <div class="k-grid-content">
            <table cellspacing="0">
              <colgroup>
                <col />
                <col />
                <col />
                <col />
                <col />
              </colgroup>
              <tbody>
                @foreach (var item in Model.EventFundings)
                {
                                         <tr >
                                          <td>
                                            @item.FundingCostTypeTitle
                                          </td>
                                          <td>
                                            @item.EstimateCost
                                          </td>
                                          <td>
                                            @item.ActualCost
                                          </td>
                                          <td>
                                            @item.Description
                                          </td>
                                        </tr>
                }
              </tbody>
            </table>
          </div>
        </div>
  2. ColinBowern
    ColinBowern avatar
    51 posts
    Member since:
    Aug 2012

    Posted 11 Aug 2012 Link to this post

    Did you try settings scrollable to false? (i.e. $("#grid').kendoGrid({ ...., scrollable: false, ... });
  3. Kendo UI is VS 2017 Ready
  4. Ryan Lege
    Ryan Lege avatar
    42 posts
    Member since:
    Sep 2008

    Posted 13 Aug 2012 Link to this post

    I tried that and it only applies it to the Header. The rest of the grid still has the scroll. My table structure must be wrong.
Back to Top