Horizontal scrollbar not working with static header

9 posts, 1 answers
  1. Jagz W
    Jagz W avatar
    17 posts
    Member since:
    Mar 2012

    Posted 22 May 2013 Link to this post

    Hi,

    I have set UseStaticHeader property true for radgrid. Grid width and height is fixed. Horizontal scrolling is working for header in IE but in chrome and mozilla its not working.


    Screen short attached.

    Thanks,
    Jagz W.
  2. Answer
    Shinu
    Shinu avatar
    17764 posts
    Member since:
    Mar 2007

    Posted 22 May 2013 Link to this post

    Hi Jagz W,

    I have tried the scrolling with an example in all the browsers ,it works fine for me.
    Please check the code below to see if it helps you.

    ASPX:
    <telerik:RadGrid ID="RadGrid1" DataSourceID="Sqldatasource1" Width="500px" Height="500px"
               runat="server" AutoGenerateColumns="false" AllowRowSelection="true">
               <MasterTableView>
                   <Columns>
                       <telerik:GridBoundColumn DataField="OrderID" HeaderText="OrderID" UniqueName="ID">
                       </telerik:GridBoundColumn>
                       <telerik:GridBoundColumn DataField="OrderDate" HeaderText="OrderDate"
                        UniqueName="OrderDate"></telerik:GridBoundColumn>
                       <telerik:GridBoundColumn DataField="ShippedDate" HeaderText="ShippedDate"
                        UniqueName="ShippedDate"></telerik:GridBoundColumn>
                       <telerik:GridBoundColumn DataField="ShipCountry" HeaderText="ShipCountry"
                        UniqueName="ShipCountry"></telerik:GridBoundColumn>
                       <telerik:GridBoundColumn DataField="ShipPostalCode" HeaderText="ShipPostalCode"
                       UniqueName="ShipPostalCode"></telerik:GridBoundColumn>
                   </Columns>
               </MasterTableView>
               <ClientSettings Scrolling-AllowScroll="true" Scrolling-UseStaticHeaders="true">
               </ClientSettings>
           </telerik:RadGrid>

    Thanks,
    Shinu
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Jay
    Jay avatar
    19 posts
    Member since:
    Dec 2011

    Posted 07 Oct 2013 Link to this post

    HI Shinu

    ,

     

    I tried the same

    as mentioned by you but no use. it is working fine in firefox and IE but Notifications in google chrome. when i scroll to the right the headers stays leading to improper display of columns

    Regards,
    Jay

     

  5. Shinu
    Shinu avatar
    17764 posts
    Member since:
    Mar 2007

    Posted 07 Oct 2013 Link to this post

    Hi Jay,

    It's hard to identify what may be the problem,check the following points,if this doesn't help,provide your full code snippet.

    *When scrolling is enabled and UseStaticHeaders is True, the grid columns should declare HeaderStyle.Width.
    * TableLayout property of MasterTableView should be set to Fixed.

    Thanks,
    Shinu
  6. Aris
    Aris avatar
    4 posts
    Member since:
    Jan 2015

    Posted 27 Feb 2015 Link to this post

    Another clue to this problem.

    It is working on my dev web server, does not on IIS7!
  7. Aris
    Aris avatar
    4 posts
    Member since:
    Jan 2015

    Posted 27 Feb 2015 in reply to Aris Link to this post

    Aris said:Another clue to this problem.

    It is working on my dev web server, does not on IIS7!


    by the way it works if I don't use the custom header X-UA-Compatible with value IE=Edge
  8. Aris
    Aris avatar
    4 posts
    Member since:
    Jan 2015

    Posted 27 Feb 2015 in reply to Aris Link to this post

    works is I remove X-UA-Compatible IE=Edge
  9. Muhammad
    Muhammad avatar
    3 posts
    Member since:
    Jan 2016

    Posted 19 Oct Link to this post

    Hi All,

    Issue:

    I had an issue when I use telerik DataForm with telerik RadGrid, the Form looked cut off when you publish to server but ok when running from local machine.

    Solution:

    has to be a combination of two things:

    1- for the form issue make the top of your html side to your web form or MasterPage look like this:

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en-us">
    <head runat="server">
    <title></title>
    <meta name="viewport" http-equiv="Content-Type" content="text/html; charset= UTF-8" />
    <meta http-equiv="x-ua-compatible" content="IE=Edge"/>

    this will fix the form issue but will cause the horizontal scrollbar to disappear from the RadGrid.

    2- then to fix the RadGrid go to the MasterTableView of the RadGrid and set width to 100%

    hope this will help

  10. Muhammad
    Muhammad avatar
    3 posts
    Member since:
    Jan 2016

    Posted 19 Oct Link to this post

    Hi Aris,

    I replied to your question, hope it'll be posted after 24 hours as they indicated.

    regards

Back to Top
UI for ASP.NET Ajax is Ready for VS 2017