Hitting browser's back button from a RadWindow loses parameters used in the parent window

2 posts, 0 answers
  1. Nekud
    Nekud avatar
    4 posts
    Member since:
    May 2013

    Posted 29 May 2013 Link to this post

    I have a Telerik Report which uses some parameters to generate the report. It generates the report fine in all circumstances except when I open a RadWindow and hit the browser's back button. The Radwindow when opens refreshes the report and generates the report in the background fine which means it still has the parameters. The report is fine even when I close the radwindow through its close button. But if I hit back button to go to the report from the radwindow the report loses the parameter (this is my best guess) and the report gives errors in red boxes. Is there a way that I can make it not lose the parameters and get the report back.
    Note: If I hit browser's back button from any page other than radwindow to this report, the report runs fine.
    I would appreciate the help.
    Thank you,
    Nekud
  2. Slav
    Admin
    Slav avatar
    1355 posts

    Posted 03 Jun 2013 Link to this post

    Hi Neelam,

    I am afraid that the provided information is not enough to determine what is the exact problem. Please provide a more detailed description of the approach for passing the parameters you are using and how is the RadWindow opened. If possible, send a simple, fully runnable project that demonstrates your implementation. Note that the use of Telerik Reporting is not needed in such a sample, you can utilize a simple page to display the parameters.

    Regards,
    Slav
    Telerik
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  3. UI for ASP.NET Ajax is Ready for VS 2017
Back to Top