Handler not Found, Execution of the hadler failed! The Remote Service Returned an Error:NOt Found.Check the Upload Buffer Size property Remarks

10 posts, 0 answers
  1. Vuyiswa Maseko
    Vuyiswa Maseko avatar
    187 posts
    Member since:
    Jan 2010

    Posted 30 May 2011 Link to this post

    Good Day

    i am using the Radupload and i have stepped through the code and it looks fine, when i host i get the Error on the image that i attached.


    Handler not Found, Execution of the hadler failed! The Remote Service Returned an Error:NOt Found.Check the Upload Buffer Size property Remarks

    thanks

  2. Tina Stancheva
    Admin
    Tina Stancheva avatar
    3298 posts

    Posted 01 Jun 2011 Link to this post

    Hello Vuyiswa Maseko,

    Can you try defining the UploadHandler URL like so:

    string sBaseUrl = Application.Current.Host.Source.ToString().ToLower();
    int iIndexOfClientBin = sBaseUrl.IndexOf("/clientbin");
    sBaseUrl = sBaseUrl.Substring(0, iIndexOfClientBin);
    radUpload.UploadServiceUrl = sBaseUrl + "/SampleUploadHandler.ashx";


    We recently had similar reports and the clients managed to fix them using this approach. Please give it a try and let us know how it goes.

    All the best,
    Tina Stancheva
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. DevCraft banner
  4. Vuyiswa Maseko
    Vuyiswa Maseko avatar
    187 posts
    Member since:
    Jan 2010

    Posted 01 Jun 2011 Link to this post

    i got a solution for this, i increased the timeout on my web-config to 2147483647 and after that i implemented the pause feuture you demonstrated here and it is working now. Please fix that Documentation the last part is not correct.

    Thanks
  5. Petar Mladenov
    Admin
    Petar Mladenov avatar
    2891 posts

    Posted 07 Jun 2011 Link to this post

    Hello Vuyiswa Maseko,

    Thank you for your cooperation. We'll fix this article today. We also updated your telerik account points.


    Kind regards,
    Petar Mladenov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  6. Vuyiswa Maseko
    Vuyiswa Maseko avatar
    187 posts
    Member since:
    Jan 2010

    Posted 07 Jun 2011 Link to this post

    Thank you :)
  7. Lee Weisenberger
    Lee Weisenberger avatar
    72 posts
    Member since:
    Nov 2009

    Posted 13 Jan 2012 Link to this post

    Vuyiswa, I'm running into the same problem you were.  Some users can upload files properly, but others experience this error on the same site.

    Could you tell me what timeout values you actually changed in the web.config file to get this to work properly?

    Thank you.
  8. Vuyiswa Maseko
    Vuyiswa Maseko avatar
    187 posts
    Member since:
    Jan 2010

    Posted 13 Jan 2012 Link to this post

    hi Lee 

    In your Web config change the MaxSize to "2147483647", if you still have a problem, please let me know. 
  9. Lee Weisenberger
    Lee Weisenberger avatar
    72 posts
    Member since:
    Nov 2009

    Posted 13 Jan 2012 Link to this post

    Thanks for the quick reply, but I'm not sure what section of the web config that goes in.  That attribute isn't in my existing web config file.

    Thanks
  10. Vuyiswa Maseko
    Vuyiswa Maseko avatar
    187 posts
    Member since:
    Jan 2010

    Posted 14 Jan 2012 Link to this post

    i am sorry for a Late Reply. i felt asleep last night. i am in South Africa.

    please send me your web config and and i will update it for you and send it back. Please don't send sensitive credentials just add dummy password. 

  11. Lee Weisenberger
    Lee Weisenberger avatar
    72 posts
    Member since:
    Nov 2009

    Posted 15 Jan 2012 Link to this post

    Vuyiswa, I really appreciate you taking a look at this for me.  The web.config file has caused me a lot of difficulties in the past when trying to resolve timeout issues.  I have attached my web.config file for your review.

    Thanks again.
    <?xml version="1.0" encoding="utf-8"?>
    <!--
      For more information on how to configure your ASP.NET application, please visit
      -->
    <configuration>
      <configSections>
        <sectionGroup name="applicationSettings" type="System.Configuration.ApplicationSettingsGroup, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089">
          <section name="CAXDock_RiaServices.Web.Properties.Settings" type="System.Configuration.ClientSettingsSection, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false" />
        </sectionGroup>
      </configSections>
      <system.webServer>
        <modules runAllManagedModulesForAllRequests="true">
          <add name="DomainServiceModule" preCondition="managedHandler" type="System.ServiceModel.DomainServices.Hosting.DomainServiceHttpModule, System.ServiceModel.DomainServices.Hosting, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
        </modules>
        <validation validateIntegratedModeConfiguration="false" />
      </system.webServer>
      <system.web>
        <membership>
          <providers>
            <clear />
            <add name="AspNetSqlMembershipProvider" type="System.Web.Security.SqlMembershipProvider, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" connectionStringName="LocalSqlServer" enablePasswordRetrieval="false" enablePasswordReset="true" requiresQuestionAndAnswer="true" requiresUniqueEmail="false" passwordFormat="Hashed" maxInvalidPasswordAttempts="5" minRequiredPasswordLength="7" minRequiredNonalphanumericCharacters="1" passwordAttemptWindow="10" passwordStrengthRegularExpression="" applicationName="/" />
          </providers>
        </membership>
        <authentication mode="Forms">
          <forms timeout="2" loginUrl="~/LoginPage.xaml" slidingExpiration="false" />
        </authentication>
        <roleManager enabled="true"></roleManager>
        <httpModules>
          <add name="DomainServiceModule" type="System.ServiceModel.DomainServices.Hosting.DomainServiceHttpModule, System.ServiceModel.DomainServices.Hosting, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
        </httpModules>
        <compilation debug="true" targetFramework="4.0">
          <assemblies>
            <add assembly="System.Data.Entity, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
          </assemblies>
        </compilation>
        <sessionState timeout="60" />
      </system.web>
      <connectionStrings>
        <add name="CA_XDOCKEntities" connectionString="metadata=res://*/CrossDockDBModel.csdl|res://*/CrossDockDBModel.ssdl|res://*/CrossDockDBModel.msl;provider=System.Data.SqlClient;provider connection string="Data Source=localhost;Initial Catalog=CA_XDOCK;Persist Security Info=True;User ID=username;Password=password;MultipleActiveResultSets=True"" providerName="System.Data.EntityClient" />
        <remove name="LocalSqlServer" />
        <add name="LocalSqlServer" connectionString="Data Source=localhost;Initial Catalog=CA_XDOCK;Persist Security Info=True;User ID=username;Password=password" providerName="System.Data.SqlClient" />
      </connectionStrings>
      <system.serviceModel>
        <behaviors>
          <serviceBehaviors>
            <behavior name="">
              <serviceMetadata httpGetEnabled="true" />
              <serviceDebug includeExceptionDetailInFaults="false" />
              <dataContractSerializer maxItemsInObjectGraph="655360" />
            </behavior>
          </serviceBehaviors>
        </behaviors>
        <serviceHostingEnvironment aspNetCompatibilityEnabled="true" multipleSiteBindingsEnabled="true" />
      </system.serviceModel>
      </system.serviceModel>-->
      <applicationSettings>
        <CAXDock_RiaServices.Web.Properties.Settings>
          <setting name="CAXDock_RiaServices_Web_WebServiceReference_Service" serializeAs="String">
          </setting>
        </CAXDock_RiaServices.Web.Properties.Settings>
      </applicationSettings>
    </configuration>
Back to Top
DevCraft banner